Cant' connect with flotilla-python


#1

Hi there
My kit arrived yesterday. So far working fine with Rockpull. However I can’t get flotilla_python to work. I’ve stopped flotilla service, but when I try the example blink script with the matrix attached, I get the error No port specified and none found! from init.py
If I type lsusb In can see an entry MCS wth ID 16d0:08c3 which I think is the dock (it disappears if I unplug it)
also sudo ls /dev/tty* gives output which includes /dev/ttyACMO and /dev/ttyAMAO
and pip3 list includes
flotilla (0.0.2) and pyserial(2.6)
Where do I go from here to get it working? I’ve tried this with the same result on two Pi2 with different SD cards both with latest Jessie.


#2

see this topic:
http://forums.pimoroni.com/t/change-in-git-to-line-71-in---init---py/1737

… seems a recent change may have brought some locusts…


#3

Yes that would seem to be the problem I reset my git download to the commit BEFORE that line was changed and everything worked perfectly.


#4

I think I’ve done a whoopsie and made it depend upon a not generally installed version of Python Serial. It should probably try to detect both ways, or use a more elegant solution.