No port specified and none found


#1

I installed the Flotilla Python API but when I run the mini-kit example I get a “No port specified and none found!” error:

pi@raspberrypi ~/flotilla-python-master/examples $ python mini-kit.py

This example requires a Touch and Rainbow module,
you’ll find these in the mini kit.

Use the buttons on the Touch module to control
your mood lighting!

Press Ctrl+C to exit.

Traceback (most recent call last):
File “mini-kit.py”, line 18, in
‘eight’: flotilla.Rainbow
File “/usr/local/lib/python2.7/dist-packages/flotilla/init.py”, line 74, in init
raise AttributeError(“No port specified and none found!”)
AttributeError: No port specified and none found!

Any idea why?


#2

Is your Pi seeing Flotilla? What do you see when you:

ls /dev/tty*

And:

sudo lsusb

The Python library should look for a connected Flotilla dock automagically.


#3

pi@raspberrypi ~/flotilla-python/examples ls /dev/tty* /dev/tty /dev/tty11 /dev/tty15 /dev/tty19 /dev/tty22 /dev/tty26 /dev/tty3 /dev/tty33 /dev/tty37 /dev/tty40 /dev/tty44 /dev/tty48 /dev/tty51 /dev/tty55 /dev/tty59 /dev/tty62 /dev/tty9 /dev/tty0 /dev/tty12 /dev/tty16 /dev/tty2 /dev/tty23 /dev/tty27 /dev/tty30 /dev/tty34 /dev/tty38 /dev/tty41 /dev/tty45 /dev/tty49 /dev/tty52 /dev/tty56 /dev/tty6 /dev/tty63 /dev/ttyAMA0 /dev/tty1 /dev/tty13 /dev/tty17 /dev/tty20 /dev/tty24 /dev/tty28 /dev/tty31 /dev/tty35 /dev/tty39 /dev/tty42 /dev/tty46 /dev/tty5 /dev/tty53 /dev/tty57 /dev/tty60 /dev/tty7 /dev/ttyprintk /dev/tty10 /dev/tty14 /dev/tty18 /dev/tty21 /dev/tty25 /dev/tty29 /dev/tty32 /dev/tty36 /dev/tty4 /dev/tty43 /dev/tty47 /dev/tty50 /dev/tty54 /dev/tty58 /dev/tty61 /dev/tty8 pi@raspberrypi ~/flotilla-python/examples sudo lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 050d:1102 Belkin Components F7D1102 N150/Surf Micro Wireless Adapter v1000 [Realtek RTL8188CUS]

This is on a Raspberry Pi Model B, on a Raspbeery Pi Model B 2 works fine after upgrading pyserial library. I did the same on the first Pi but Im still getting the same error.


#4

It seems like it doesnt show up, but the Dock seems to do the initialization and the touch sensors work because the leds on the sensor and on the dock lights up when I touch any of the buttons.


#5

Do you mean B (26 pin GPIO main header) or B+ (40 pin)? Running what OS… I suspect there might be a bunch of dependencies, or perhaps kernel modules not available?


#6

It should just work, try wiggling the USB cable at the dock end and see if it makes any difference. It may be that you’ve got one with a slightly marginal USB port, which survived long enough to get it through testing. If so we’ll replace it, of course.

Alternatively, and to eliminate it as the cause, have you tried both another USB port, and another USB cable?

It sounds like the dock is getting power, which would explain why it appears to work, but it wont do much without any USB communication.


#7

I meant B (26 GPIO main header) https://www.raspberrypi.org/products/model-b/


#8

I tried both USB ports, I didnt try any other USB cable but I doubt is that since the docks and the touch boards work and also it works on my other Raspberry Pi 2 Model B.

So with:
Raspberry Pi Model B - Doesnt work
Raspberry Pi 2 Model B - It works


#9

Could it be a power issue? The B is sizeably more power hungry than more recent iterations.

On the other hand, if, as implied by your other forum thread, it’s a headless Pi then that shouldn’t make much difference.

But I would encourage you to describe your software environment in much more details, it is very hard right now to see the bigger picture and find a hopeful lead to follow!


#10

Sorry my fault. It was stupid mistake of mine about the IPs of the two Raspberrys I have. It works on both. The only thing I had to do in both Pies is to install pyserial.