Can't get Inky Phat working on Zero W

Hi, I’m new to Raspberry Pi and am failing to get the Inky Phat to update at all when I run the example scripts.

So far I can’t even determine if this is a software or a hardware/installation issue or software problem.

Hardware notes

  • I’m using the Zero W Complete Starter Kit from Vilros, which includes a 2x20-pin Strip Dual Male Header.
  • The Pimoroni Getting Started page says no soldering is required, so I’ve just used the header to connect the Inky Phat to the Zero W board. Here’s a photo. It’s a little loose but stays in place. In all my Youtube and web searches I cannot find a picture of someone actually showing how they connect the Inky Phat to the Pi. Is this right?
  • I actually have to Inky Phats and have tried both with no results, so it’s not likely to be a faulty unit.

Software notes

  • uname says I’m running Linux raspberrypi 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l GNU/Linux
  • Generally the OS seems to work ok in general, though it has crashed more than once. I’ve enabled SSH and can access the Pi from my mac.
  • In my first run of curl | bash, I got some errors about packages not being available.
  • In my first runs of the test scripts, I got the “i2c is not enabled” errors. I switched that on through the GUI/preferences, and now when I run the scripts, I don’t get any errors. But the Inky Phat never updates.
  • I’ve tried running the scripts with python3... instead of python... with no effect.

Any help would be appreciated — thanks!

No soldering is required for the Phat, but the Pi Zero absolutely needs a permanently attached header. Sliding a pin header into the holes won’t be secure enough for a proper connection. If you’re not comfortable soldering a header to the Zero Pimoroni make Hammer Headers, or the Pi Zero WH comes with a header pre-soldered, whenever they’re in stock.


Ah, thank you very much!