Dead Pi 4 with Red LED blinking x3

I had been quite excited to house a Raspberry Pi 4 8 GB in an old Macintosh Classic Case. But, I think I might have killed the Pi. I had it connected to HiFi Berry Amp 2 and tried to power the whole set up through: “ALITOVE AC 100-240V to DC 24V 5A Power Supply Adapter Converter with 5.5 x 2.1mm 2.5mm DC Output Jack for 5050 3528 LED Strip Module Light” The makers of HiFi Berry had recommened a 12 to 24 voltage power source. I plugged the DC power through the HiFi Berry Amp DC. Everything went on a few seconds and then stopped. I unhooked everything and checked my connections. The PI red LED blinked 3 times, pause and resumed. Disconnected everything. Removed the SD card. Tried the official Pi4 power cord - still the same LED pattern. Tried a different official Pi 4 power cord. Same result. Installed EPROM recovery to SD card, inserted and tried again. I think I killed my Pi! Tried to see if the Pi would power on this morning about 12 hours later and still the same result. I couldn’t find anywhere what the red LED blinking x3 means. Since there isn’t a polyfuse I suspect that the board was fried. Just waiting to see if the community has any ideas to restore it before I buy a replacement Pi4. Thanks in advance.

It doesn’t sound good I’m afraid. I’m not sure why that would have damaged the Pi, unless it wasn’t producing the advertised voltage properly, in which case the Amp 2 might be damaged as well.

I first tried to reflash the eprom and no luck. Then, Shoe using your idea, I broke out my multimeter to test the power supply. It registered 24.85 volt and 5.85 Amps. I am not sure if that extra amperage is what fried the Pi. Maybe I’ll write to the HiFi Berry and see if there are any known issues.

Current shouldn’t be an issue, the device will pull what it needs. The only thing I can think of is that the power supply had a spike or maybe the HAT wasn’t lined up on the GPIO pins properly? Try wiping the microSD and re-writing the OS.