Pi 3A+ and B+ not working

I have a Raspberry Pi 3B+ and a brand new 3A+, both of which have the exact same problem. When the power supply (official Raspberry Pi PSU with a switch) is turned on, only the red light on the Pi comes on, and absolutely nothing happens. I have tried with two different Micro SD cards, both flashed with Raspbian. I’ve even tried flashing them from two different computers, and I’ve tried to boot the 3B+ from a USB hard drive with Raspbian. Always the same results.
My question is, is it likely that the PSU has suddenly stopped working (the 3B+ did use to work with that PSU), and that that’s causing only the red light coming on with no activity?

I have had that situation with a Pi Zero W and it turned out to be poor electrical contact of the SD card in its socket. Fluff or a small piece of paper, was the culprit.

Could you post a link to that power supply? Non of the official ones I’ve seen have an on off switch?

It was bought from ModmyPi last year, which I believe is the Pi Hut now. On the order details, it shows as “Power Supply - UK Plug 5.1V 2.5A with Switch”, so I suppose it’s not actually official.
I’m just considering whether it’s worth it buying a new PSU, which is why I’m asking if it’s the sort of issue that could typically be caused by a bad PSU.

I wish I could advise you about it being a power supply issue, but I can’t say yes or no based on what you have posted?
Do you see anything on the monitor?
What procedure are you using to create your Micro SD cards?

Apologies for not being precise enough. I used to have my Raspberry Pi running headless so did not use a monitor. I have, however, tried to boot it with the full version of Raspbian with the UI, connected with HDMI, and absolutely nothing happens. As I said, the red power light comes on, and that’s it. The green activity light never even flashes.

Both micro SD cards were flashed with Balena Etcher, which I understand to be the preferred method. I have also tried with the application from the Raspberry Pi website that downloads and flashes, again same result.

With two different Pis and three different storage devices flashed from two different computers but only the one PSU, I suppose the PSU is likely to be the culprit. What confuses me is that I’ve never heard of PSU issues showing like this, I thought with the graphical version of Raspbian that it would still show something.

A new power supply would be the way I would go if it was me. I have several here as I have several different Pi builds on the go.

There is a good post on the raspberrypi.org forum about boot problems, here. Suggests if the LED is lighting up the power supply is OK (I use a variety of power supplies for my PIs, phone & tablet chargers and never had a problem). That post gives lots of hints about what to try.