Display HAT Mini as Linux Console?

I’ve been using a number of the Adafruit Mini Pi TFT displays as a Linux console display. This would seem to be possible with the Display HAT Mini since I believe it’s using the same underlying ST7789 library. Given that, I’d assumed (apparently mistakenly) that it would be possible to use the Display HAT Mini in this same capacity, but seeing no example, my subsequent attempt at using the Adafruit installer for the 320x240 ST7789 failed.

Is there a way to use the Display HAT Mini as a Linux console?

See if this helps, I haven’t tried it myself.
juj/fbcp-ili9341: A blazing fast display driver for SPI-based LCD displays for Raspberry Pi A, B, 2, 3, 4 and Zero (github.com)

Thanks for that, I’ll give it a try. The investment is the time it takes to flash an SD card, do the install and see what happens… but that looks more promising than using the stock Adafruit installer.

Well, I tried the juj library and realised it didn’t seem to support the Pimoroni HAT, but found the Pimoroni forked (PR) at https://github.com/pimoroni/fbcp-ili9341/tree/feature/pimoroni-display-hat-mini and built that using the following command line:


I wasn’t sure about the last directive so I set it to -1. I was able to build it but when executing fbcp-ili9341 I ended up with a failure:

bcm_host_get_peripheral_address: 0x3f000000, bcm_host_get_peripheral_size: 16777216, bcm_host_get_sdram_address: 0xc0000000
BCM core speed: current: 400000000hz, max turbo: 400000000hz. SPI CDIV: 40, SPI max frequency: 10000000hz
Allocated DMA channel 7
Allocated DMA channel 1
Enabling DMA channels Tx:7 and Rx:1
DMA hardware register file is at ptr: 0x75c67000, using DMA TX channel: 7 and DMA RX channel: 1
DMA hardware TX channel register file is at ptr: 0x75c67700, DMA RX channel register file is at ptr: 0x75c67100
Resetting DMA channels for use
DMA all set up
Initializing display
Creating SPI task thread
InitSPI done
vc_dispmanx_display_open failed! Make sure to have hdmi_force_hotplug=1 setting in /boot/config.txt

And to note, I have set hdmi_force_hotplug=1 in /boot/config.txt and rebooted. So I’m now at a bit of a loss, maybe just wait until someone at Pimoroni has this working and the PR has been merged. I’m nowhere near the C programmer necessary to debug what’s actually going wrong here.

Way above my skill level, that’s for sure. Bummer.

I’ve got this sort of working with a raspberry pi 4 (buster).
Far from being an professional I did the following steps:

  1. git clone https://github.com/pimoroni/fbcp-ili9341.git
  2. Edited the changes for the 5 files by hand with copy and paste wich are shown here (didn’t manage to download this)
    (in the build directory)
  4. make -j
    sudo ./fbcp-ili9341
  5. If your raspi is configured to start with the desktop your display should be cloned to the display hat mini.


1 Like

This got me pretty far, however step #4 brings me a ‘command not found’ error when attempting to do:
sudo ./fbcp-ili9341 part. Does this make sense?


I’m trying to get the same working up.
Did you add any overlays by any chance?
My screen comes out blank after doing the same as your steps. I’m using a Raspberry Pi Zero W.

You have to be in the directory where the binary was compiled to.
Take a look with „ls“ and/or cd up or down till you found it.