Display-O-Tron 3000


I’ve tested against the latest version of RPi.GPIO and it still works for me, leading me to conclude that, perhaps, you have an older version or a broken install of the package.

Try running this command and then try again:

sudo pip install rpi.gpio --upgrade


Thanks, I’ll try that tonight and report back. :)


Brilliant! That fixed it! Thanks again for the help, much appreciated. I can now finish work on my super awesome, insanely difficult anagram game. :)

One last question (for now), I seem to have to re-run sudo modprobe i2c-dev everytime I restart the pi. Is this expected / normal?

[Edit: sadly as a new user, I can’t actually reply to this thread any more or post a picture of the project I’ve been working on. Still, I’ll read and appreciate any further information. Cheers]


Looks like you don’t have the i2c module set to be loaded by default. You can follow the instructions here to fix that: https://learn.adafruit.com/adafruits-raspberry-pi-lesson-4-gpio-setup/configuring-i2c


I’ve changed your status to member, I’m still not entirely sure what that does, but hopefully gets you back in the flow!


Yep, that seemed to be the problem. Sorted it now. Cheers


Thanks, I’ll use my new powers responsibly ;)

As I said above, the first dot3k project I’ve been working on has been an anagrams game. My actual use of the dot3k might not be that impressive at the moment, but this project has been a real challenge for me to code. I was going to use the joystick to access / manage some sort of scoring system for the game, but the game is actually so difficult, I’ve yet to score a single point.

Here’s a picture, you have 30 seconds to solve the anagram :)


Yikes! You’re not going for easy words :D That’s for sure.

You could use the joystick to pick the letters in order onto the row below/above to solve it, and score based on time taken?


Yeah, I probably didn’t think though how difficult 10 letter anagrams would be…

I had thought about having something like that, but that’s a step beyond what I can do at the moment really, I’ve got a bit of work to do to figure out how to use the code for the joystick before I can get that far. I’m starting with putting in a difficulty selection menu at the beginning of the game.

When I conceived the idea the game was based on solving the anagram in a fixed amount of time (you can’t really see it in the picture, but the bargraph LEDs count down 30 seconds before the solution is displayed) and I’d like to keep that mechanism really, so figuring out the solution and typing it in would be a bit difficult in this time. Having the joystick pick the letters would be a fun variation and a good next step though, perhaps I’ll create different game modes.


Sounds like it’s making you learn things, though, which is by all measures a success. Keep us posted!


Is there an interface spec sheet?. Something with power specs and the commands supported by it.
I’m looking to use it as a display for a small custom computer with USB Host that doesn’t have python.
I’m in California so where would be the best place to get one if it meets the requirements.
Many thanks


The Display itself is very explicitly detailed in the datasheet. Even on a host with no SPI hardware, it would be possible to run SPI over a few regular GPIO pins.

The display ( DOGM163-A ) datasheet is here: http://www.lcd-module.com/eng/pdf/doma/dog-me.pdf
The driver IC datasheet is here: http://www.lcd-module.com/eng/pdf/zubehoer/st7036.pdf

This code is for driving the display, it’s for Arduino but should be a good starting point for your setup: https://code.google.com/p/doglcd/

This code, again for Arduino, is for the SN3218 LED driver which talks over i2c. If you don’t have any dedicated i2c hardware it would be slightly more complex to get it up and running and you’d need some pullup resistors.

Is your small custom computer based on a Raspberry Pi?


Hello Phil
Thanks for the answer.
I’m looking at it for a demo output of a product, using the USB interface.
So a data sheet is really to try and understand all on one page what the physical interfaces, mech, power spec are.
Right now I like the look of the product, but feel I’m fruitlessly hunting down small specification details.
I’m using an Arm Cortex-M3 Kinetis K20 - same as the Arduino Teensy3 - the product is a “Logger” but with a USB Host capability that is specified to manage a USB Stick and log data to the USB Stick.
For the demo, I want to swap the USB stick for your display.
So in the Processor code in demo mode, I would detect the USB CDC plugged in and then send the “demo mode” values to the display.
I’ve pulled down the ST7036 module and doglcd code - so I can see what is going on.

What I need is for all the physical information to be simply accessible - so I must have been mistaken that the Display-o-tron-3000 has a USB interface.
What I think I’m going for is the Matrix Oribital LK162B-7T-USB - it doesn’t look as good as what you are displaying - but has a USB interface.

many thanks


You’re correct- Display-o-Tron 3000 doesn’t have a USB interface, but has a 40-pin header designed to connect directly to the Raspberry Pi.


Hi all - I’ve had a Pi since day one, managed to get one of the very first … it’s been used as a web server since 2012 :)

I got my hands on the DoT3k this morning on a fresh rebuild of the Pi, I can’t get it to work. So many questions but the most important is :

  • Is it compatible with revision 2, i.e the first tranche of Pi’s to be shipped?

processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 2.00
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 0002
Serial : 0000000087c26b89

It looks like SPI isn’t loading, I’ve started with a fresh Raspian build, upgraded, updated the firmware, installed Dot3k etc and followed the tutorials on here step by step and my LSMOD looks like this:

Module Size Used by
w1_therm 3325 0
w1_gpio 4068 0
wire 31280 2 w1_gpio,w1_therm
cn 5756 1 wire
i2c_dev 6709 0
snd_bcm2835 21342 0
snd_pcm 93100 1 snd_bcm2835
snd_seq 61097 0
snd_seq_device 7209 1 snd_seq
snd_timer 23007 2 snd_pcm,snd_seq
snd 67211 5 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
8192cu 569585 0
uio_pdrv_genirq 3666 0
uio 9897 1 uio_pdrv_genirq


Running the Hello World script gives me the following:

Traceback (most recent call last):
File “./hello_world.py”, line 3, in
import dot3k.lcd as lcd
File “/usr/local/lib/python2.7/dist-packages/dot3k/lcd.py”, line 3, in
lcd = st7036.st7036(register_select_pin=25)
File “/usr/local/lib/python2.7/dist-packages/st7036.py”, line 20, in init
self.spi.open(0, spi_chip_select)
IOError: [Errno 2] No such file or directory

Would really appreciate some pointers - Thanks guys


Wowser, this is a new one. Can you try the installer script?

curl https://get.pimoroni.com/dot3k | bash

Dot3k not working after apt-get upgrade to support Pi 2

Hey fast response - Thanks

I just used the script, chose the options to re-install everything then rebooted. Still not working?

pi@Rasp1 ~/Pimoroni/dot3k/basic $ ./hello_world.py

pi@Rasp1 ~/Pimoroni/dot3k/basic $ ./hello_world.py
Traceback (most recent call last):
File “./hello_world.py”, line 3, in
import dot3k.lcd as lcd
File “/usr/local/lib/python2.7/dist-packages/dot3k/lcd.py”, line 3, in
lcd = st7036.st7036(register_select_pin=25)
File “/usr/local/lib/python2.7/dist-packages/st7036.py”, line 20, in init
self.spi.open(0, spi_chip_select)
IOError: [Errno 2] No such file or directory

Can it be the Pi board is the wrong version ?


Ah… I just read this step: “updated the firmware.”

Did you run rpi-update?

The latest firmware totally changes how things like I2C and SPI are handled/enabled, so that could be our culprit.


sudo apt-get install --reinstall raspberrypi-bootloader

And reboot.

I think that’s the right command, going to have to fire up my Pi to double-check.


You sir are a genius … many thanks, that did the trick, the only reason I did the update in the first place was to get a wifi dongle working.

Thanks again


Brilliant! I’ve added a new topic warning people away from rpi-update, and giving a brief how-to-fix-it and what-to-do-if-you-wanted-to-update. I don’t anticipate that this will be the last of these problems though!