Enviro Grow Uploads to Adafruit.IO result i. Errors

Hello community,

I own an Enviro Grow + Accessory Kit and have configured to upload the sensor readings to Adafruit.IO (free account).
This had been working pretty well. But since last week I keep on getting errors „data created_at may not be in the future“.
What does this mean? Is my RTC out of sync? Do I need to resync the RTC from an NTP server? (I have already attempted to execute the ntp.py Script from inside phew/phew folder with no success)
Or is this related somehow to daylight-saving time?
How can I get rid of this issue? (I noticed that this issue yields flashing the red LED which in turn seems to impact the battery voltage and lifetime)

Looking forward to get any hints or help from you!

Cheers, SickNature

Can you post the contents of the log file on your device after it starts flashing the red LED?

Details of what firmware version you’re running and how often you’re sending your data to Adafruit could also be handy.

p.s. if you want to reset the RTC the easiest way of doing that is by disconnecting your battery and USB from the board for a few seconds - it will then attempt to grab the right time from the ntp server when it next starts up.

Hi Hel,

For now it seems that resetting the RTC has worked well. I will observe this issue for another week and if this keeps on working I will close this thread.

Best regards,

1 Like

Hi Hel, please consider this issue as [solved]!
My Enviro is working again as expected, no more upload errors.

And for the future I know how to resync the RTC!



1 Like

I think there’s some intermittent bug at the moment where the NTP server occasionally returns a weird date and it causes things to get stuck - we’ll hopefully be able to squash it in a future release :)