Enviro Indoor data logging to InfluxDB in Docker

Hello fellow buccaneers!

I have just started playing around with the enviro indoor board and have successfully managed to upload logs to adafruit.io. But I would prefer keeping everything on my local network so I set up InfluxDB in Docker with a bucket “enviro” and everything seems to be up and running on that end. Ports are exposed and I am able to make api calls via terminal.

I also have upgraded the enviro’s firmware to v0.0.8 btw.

I have run the provioning on the enviro and entered the IP and port number of the InfluxDB container and the bucket name as it is written in the enviro documentation.

But all I get when the enviro tries to upload the logs is a blinking red light. The log only show the following:

2022-09-10 09:19:02 [error    / 115kB] ! failed to upload '2022-09-10T09:17:34Z.json' to influxdb
2022-09-10 09:19:02 [error    / 113kB] ! reading upload failed
2022-09-10 09:19:02 [info     /  96kB] > going to sleep
2022-09-10 09:19:02 [debug    /  94kB]   - clearing and disabling timer and alarm
2022-09-10 09:19:02 [info     /  92kB]   - setting alarm to wake at 09:30am
2022-09-10 09:19:02 [info     /  90kB]   - shutting down
2022-09-10 09:19:03 [debug    /  88kB]   - on usb power (so can't shutdown) halt and reset instead

The documentation for the InfluxDB destination says that I only need to enter values for the “influxdb_url” and “influxdb_bucket”. Since that did not work I also tried supplying the config with values for “influxdb_org” and “influxdb_token”. Still getting the same error.

Since I have no experience with InfluxDB and the log on the enviro doesn’t tell much about the error, I don’t really know where to go :(.

I’m posting Enviro data into a InfluxDB database hosted on a Pi (learn guide coming soon!) and I only needed to enter the URL and the name of the database I’d set up in the ‘bucket’ field.

I’ve not tried it with Docker though - possible that you need to give it different details in that case?

1 Like

I am very interested in that guide. Maybe I did something wrong setting up the InfluxDB itself? I had to set up an admin user and organization to enter the admin ui and then I simply added a bucket called “enviro”. It seemed pretty straight forward but perhaps I missed something.

I don’t know what I did, but it works now! Been trying to get this to work for two days know and I’m sure I did nothing different than before. Anyways :D. I’m going to let it run for a couple of days to see if there are any quirks.

Awesome (it’s always slightly annoying when something ‘just starts working’ :D)

Learn guide is now uploaded!

1 Like

Yes it is. I will never find out why it didn’t work in the first place xD.
Thanks for the guide!

1 Like

For anyone else with this problem, when following the install guide for Influxdb you are prompted to setup a user for the ‘home’ database, with the database now secured, I encounted upload errors 404 when configuring the enviro grow.

After removing the database and recreating it, without setting up the grafana user, the enrivo grow had no issue sending data to the influxdb.

The only change in the grafana setup is there no longer being a need to set a username and password to the influxdb data source.


I am wondering if you could also include example/guide where authentication is enabled on InfluxDB.

It seems that OSS and cloud InfluxDB behaves differently and I am having difficulty with JWT Bearer auth.

Thank you.