Galactic Unicorn can't reset

I’m tinkering a bit with my Galactic Unicorn, the last thing I did was saving the as which worked fine. After that I put it in bootloader mode and copied pimoroni-picow_galactic_unicorn-v1.19.10-micropython.uf2 to it. Normally then I’m able to find it in Thonny, but not this time, even not after resetting it again and again, the only weird thing is that the rainbow example was still working. So I entered again bootloader mode and copied this special file from the getting started guide, and to be sure I installed micropython for the Galactic Unicorn via Thonny, as shown in the screenshot.

This action led to the following prompt:

Downloading from
Writing to D:\pimoroni-picow_galactic_unicorn-v1.19.10-micropython.uf2
Waiting for the port…
Warning: Could not find port in 10 seconds


Aaand the rainbow example was stil there, working like a charm, but that’s not what I want.

Any idea how to solve this?

Did you try the “configure port manually” option in Thorny? In case it switched com port numbers on you.

Thanks for the tip, if you mean by configure port manually the option in the screenshot; I tried that, sadly nothing.

I’d try the flash_nuke.uf2 to clear the memory and then re-install the correct uf2. Try clicking of the PORT menu and then click of the COM ? it finds.

You can find the instructions and the uf2 at the bottom of the page here:

1 Like

I already did that, but with the Pimoroni instructions, but no success. Will try again with the instruction you posted this weekend :)

I just drag and drop from File Explorer. I put the PICO in boot mode, then drop the flash_nuke.uf2 file to RPI-RP2. It will disappear then reappear. Then I do the same with the Pimoroni uf2 file.

1 Like

It works, thanks a lot!

1 Like

Glad you got it working. It’s a great board.