Getting started with MCP9600 and Raspberry Pi

I have a Raspberry Pi 3B+, a breakout garden, and two MCP9600 thermocouple amplifiers, and two K-type probes. I’m having a difficult time getting the Raspberry Pi to recognize even one of the amplifiers/probes. I’ve tinkered around for some time to no avail. The websites I’ve found are either cryptic or misleading. Is there a 101 type manual somewhere that can help?

Sorry, my title should have said MCP9600

Did you cut the ADDR +1 jumper on “one” of the MCP9600’s? If not, and you have them both plugged into the Breakout Garden “at the same time” you will have a conflict. No two devices on i2c can have the same address.

No, I haven’t. Good to know. However, I did try it with only one MCP9600 with the same error. I tried a couple of eclectic ways of getting to it, but I am now somewhat lost. Is there are primer on using the MCP9600 with a Raspberry Pi that I could read?

I don’t see anything for those in the Learn section.
You did the sudo pip install mcp9600 right?
What error are you getting?
The examples are here and should work.
mcp9600-python/examples at master · pimoroni/mcp9600-python (

Thank you! This worked. I had found the instructions for installing the card, but I ran into a series of unfortunate recommendations that brought me down a rabbit hole when I was looking for a simple code to test the probe. The example you linked was what I was looking for.

There is usually more than one example, but I guess one is enough if it works.
To use the second MCP9600 (that you cut the ADDR jumper on) you will have to edit the following line in the py file
m = mcp9600.MCP9600()
m1 = mcp9600.MCP9600(0x66) # no jumper cut
m2 = mcp9600.MCP9600(0x67) # jumper cut
m1 = mcp9600.MCP9600(I2C_ADDRESS_DEFAULT) # no jumper cut
m2 = mcp9600.MCP9600(I2C_ADDRESS_ALTERNATE) # jumper cut

And then anywhere m is used to call up the temp you will have to change it to m1 or m2 depending on which one you want to read.

Yes, the first solution worked. Thank you! Now it is often pulling a temperature of 16.0625 which is incorrect and is clearly an artifact of something. The pages out there suggest a couple of different solutions. What would you recommend?

I don’t have any recommendations, I don’t have one to tinker with etc. I have several Breakout Garden Breakouts, just not that particular one.

No problems. Thanks for helping out up top. I’ll dig around.

I’ve had good luck with their breakouts. So far anyway. You may get some help if you post it as an issue on the git hub page for that breakout.
Issues · pimoroni/mcp9600-python (