Google AIY voice kit - LEDs not lighting


#1

Have just assembled my kit, using an RPi 3. The audio and wifi tests work. Neither the LED on the Voice HAT nor the push button lights up.

Troubleshooting info states: “(2) If the lamp in the button doesn’t light up, it might be the wrong way around. Take the lamp out of the button (undo steps 8 to 11), turn it 180°, and put it all back together. If it still doesn’t light up, check that the wire colors are the same as the picture in step 12.”

The step “Take the lamp out of the button” is unclear. I’m unable to discern a lamp in the button. I’m unclear on whether I’m told to disassemble the button - I’ve levered off the cover and removed the white plastic inner part which has a prong which pushes down on to a circuit board. No lamp to be seen. Have replaced the white plastic inner part. Am postponing putting the button’s cover back on pending, hopefully, receiving further info.

Am I misinterpreting the instructions? Do they, perhaps, amount to telling me to wire up the button’s terminals differently from in the instructions - and not telling me to disassemble the button at all?

Wonder whether the LED on the Voice HAT not lighting is a related or a separate issue.

Unsure, at this very early stage, whether the failure to light of these LEDs actually matters.


#2

LED’s have a polarity, reverse bias them and they don’t light up. Incandescent bulbs don’t have a polarity, they work just fine with AC or DC, assuming its the correct voltage.
Looking at the pictures its hard to tell if the arcade button has an LED or bulb in it?


#3

The instructions for the reversing the lamp I think only apply to the original kit which had a different button setup. Do check your spade connectors are the right way around though.

If the LED on the board isn’t working either it might be that the service hasn’t been started?


#4

How many terminals are on the arcade button? If only 2, its unlikely that its an illuminated button. For that I would think there would be 4 terminals, 2 for the switch and 2 the indicator.


#5

@alphanumeric - 4 terminals - and they are definitely connected as per instructions:

white and black wires, which connect the button switch mechanism, attach to pins protruding from grey plastic

blue and red wires, which control the LED light on the button, attach to pins embedded in plastic the colour of the button.

I suppose I could try swapping over the blue and red wires, though that would be contrary to very clear instructions as to what connects where.


#6

Swapping the Blue and Red wires shouldn’t hurt anything. It will just reverse the polarity of the voltage going to the LED. And a lot easier than taking the switch apart. Do you have a link to the detailed instructions? I couldn’t see anything on the product page?


#7

@alphanumeric: The kit came with a booklet: “The MagPi Essentials AIY Projects Create a voice kit with your Raspberry Pi”. It contains its own instructions and also includes a link to online instructions at https://aiyprojects.withgoogle.com/voice.

Since posting here, I’ve noticed an email address for seeking support from Google, reached by clicking on Help in the online contents/navigation page at the web address shown above.

I’ve also seen that there are GitHub resources relating to this product at https://github.com/google/aiyprojects-raspbian and they include a link to a support forum.

I haven’t searched/browsed yet in that forum but that forum looks active and I may well find additional help there.

Thanks @alphanumeric and @major_tomm.


#8

From my hazy memory the AIY LED (board and external) runs off pin 25, so you might be able to knock together a little script just to check it works?


#9

Thanks for the link to the instructions, looking at it now. You appear to have followed them correctly, not sure why it doesn’t work? Just FYI, getting the polarity backwards on an LED won’t hurt it. It just doesn’t conduct. It behaves like an open circuit.


#10

@major_tomm: I’ve now seen from posts in the raspberrypi.org forum that others have also experienced the LEDs not lighting initially but lighting when some demo scripts are run. Someone else had difficulty making sense of the instruction to take the lamp out of the button and turn it around.

I’ll now ignore this issue, carry on with following the instructions as regards setting up the device to use Google Assistant, and see how I get on.

The documentation includes, at Chapter Four Step 6 in the paper booklet and Step 6 of Verify it works in the online guide, an instruction to check the LEDs on the board and inside the arcade button which should both indicate that the device is running, The online guide says both LEDs should be emitting a slow pulse.

If it turns out that this doesn’t match reality with the hardware supplied and the disk image users are directed to, it is unfortunate that users are directed to make this check.

I appreciate the difficulty of keeping documentation fully up to date when the hardware and/or software being documented is still evolving. If something is true when one version of the hardware and software is used but not with another combination, ideally there would be different versions of online instructions along with instructions to help users identify which set of instructions is applicable. If a lot of possibilities had to be catered for, though, I can see that this could get very difficult.

UPDATE:
I’ve now tried the demo python scripts which come with the disk image and the arcade button lights and functions as a button. I haven’t wired the hardware any differently. Looks like I’ve worried needlessly about the LEDs not slow pulsing when the kit is booted up.