GrowHAT pump stuttering

Hello,
I setup a small project using my old Raspberry Pi 2B and the Pimoroni GrowHAT.
I attached some sketches below. (topdown/sideview)
Part list:

  • Raspberry Pi 2B (only ethernet attached/no USB)
  • GrowHAT Mini
  • 3x moisture sensors
  • 3x 1m moisture cable
  • 3x mini pump
  • 3x 1m tube for pumps
  • camera module V3 + 2m cable
    The moisture sensors are working great, and I wrote a small Prometheus Exporter to get the metrics to my main Server.
    But I am having trouble getting the pumps to work up to specifications.
    The max water head I achieved was barely around 0.30m.
    The problem seems to be a power issue as I also have a camera module V3 attached to the Raspberry Pi and when attached, max water head is around 0.20m.
    When running a pump I can hear that the pump is working but stuttering.
    I only used tap water and a glass for testing, so pumps should not be blocked by small debris.
    I also see the growHAT screen crash and reboot.
    Probably the GrowHAT is not receiving enough power from the Pi while running the pump and starts pumping again as soon as rebooted and that is the reason for the low water head.
    For testing I used 3 different USB-chargers (two with interchanged cables/one attached) which resulted in the same behaviour. (2000mA/4500mA/2500mA) for all three pumps.
    Removing the camera improved the power of the pump but it still crashed the GrowHAT mini while pumping.
    My simple script for pumping:
from grow.pump import Pump
pump1 = Pump(1)
pump1.dose(1.0, 30.0, blocking=True)      # tried blocking true/false

While debugging I ran:

user@raspberry:~ $ /opt/vc/bin/vcgencmd get_throttled
throttled=0x0

I am not sure if I can trust this value as this indicates this is not a voltage problem rather a current one.
Is it possible to interpret the values for “Maximum total USB peripheral current draw” as the max current for the 5V rail?
Power requirements
What Raspberry Pi versions are you using for your GrowHAT-pump setups?
Is the Raspberry Pi 2B not delivering enough current to the 5V rail?
As per the documentation most raspberry-versions should behave similar.
Or do I need external power for my pumps?(What is recommended for external powering?)
Are just my USB-cables of bad quality?
Is there any way to debug this further or has anyone experienced something similar?
topdown

As only one media upload is allowed for new users, here the sideview of the setup:
sideview

Chargers or Power Supplies? I ask because there is a difference. Have you tried the Official Micro USB Power Supply?

Sadly not the official.
The original one I got with the Pi 2B died some time ago.
I ordered the official power supply again and will report back when it arrives.
I did not think that it would make that much of a difference because it had been running stable for years with a simple samsung USB-charger, but I guess high load shows the constraints.
So in theory there should be no problem if the power supply is stable?

It will help get you a more stable system. Chargers are notorious for not having a stable voltage output under load. And that’s something a Raspberry Pi doesn’t like very much. I would think 2.5A would be enough to drive the one pump?

The official power supply arrived today, sadly it is worse than the other chargers I had laying around.
I ordered it from one of the official resellers on the official pi website.
The water head is at around 0.20m when removing the camera even worse when connecting it.
So the problem must be somewhere else or the power supply is from a bad batch.
But at least the pimoroni GrowHAT does not reboot while pumping, it seems like the voltage drop has been addressed.
Now it seems current is not enogh to support a pump fully.
It does not stutter anymore but is running more silent and with less force/speed? than before.

I have a Grow Hat Mini here, setup with a Pi Zero. I’ll blow the dust off of it, and try and do some testing on it, before the day is out. I have errands to run first.

Booted it up discovered that there are no auto watering menu options on this install. I reflashed my SD Card with Legacy 32 bit so I can do a fresh install. It’s doing updates as I type this. I should have something to report before the day is out.

Ok, now I have access to the auto watering pump settings.
I’ve turned on the auto watering and near as I can tell it’s all working as advertised. I have one pump that seems noisier than the others, works OK though. No stuttering on any of the pumps. Pi Zero with the latest version of the Official Micro USB power supply.

1 Like

Thank you very much for your testing and time.
The problem lies propably with the Pi 2B, I read some other people having problems with this model powering 5V-USB-devices even with the increased power in boot-config.
I ordered a Pi Zero2 WH now to run the sensors and pump.
If power is enough for the camera I will run it also on the zero, if not I still got the 2B.
If you have an amazon wishlist or something like that I am happily willing to buy you anything up to 50$, but be aware that you have your settings setup properly, so that I can not see your address.
The correct setting should be “shareable”.

A Zero2 is likely a good choice. I found myself waiting quit a bit of the time for things to happen. while I was setting everything up, with just a Pi Zero. It will be more than fast enough for the Grow software. Spoiled by my Pi 4’s and Pi 5 I guess. It’s been a while since I’ve done an OS & software install on a Zero.

No need to buy me anything. I was going to be blowing the dust off of my Grow setup anyway. Summers here and I want to try growing some Cannabis. It’s legal here in Canada and I can grow up to three plants. Just for fun, and maybe some pleasure ;) =)

1 Like

Haha, thank you again for your support.
Thank is exactly the same thing I am trying to do.
I was not quite sure about the legal status of the forum, so I did some sketches instead of photos.
Since april 1st it is legal to own up to three platns in germany aswell.
Happy growing!

1 Like