HAT or PCB for Full Cabinet Build?


#1

Hi everyone - new to the forum here!

I’m about to get to the controller input stage of my full cabinet build and was searching around for the best way to wire up the buttons/joystick to my Pi.

The HAT and PCB both look great, but I guess I’m not sure which one to choose. I know the HAT has the ability to perform the soft shutdown, but will I lose the functionality of the 3.5mm headphone jack that comes stock on my Pi? Other than not having the soft shutdown function and not being attached to the GPIO pins, is the PCB really that different?

Thanks so much for any help!


#2

The software is quite dramatically different which could potentially mean that Picade PCB has slightly more input latency than Picade HAT but I haven’t actually put this to the test.

Picade PCB can be reconfigured to emulate a gamepad, keyboard or weird combination of the two. This is handy if you’re using it with things that don’t accept keyboard input (rare, but sometimes an issue with analog controls) or if you might use it with something other than a Pi.

You can also use two Picade PCBs in gamepad mode together (or more, though I’ve not heard of any more than two being used in any build yet) which is handy if you want extra buttons or player 2 controls. With the HAT you only get the one set of inputs, although you can still add a PCB to that anyway.

You wont lose the 3.5mm headphone jack if you opt to keep analog audio enabled and forego the amp/speaker driver on the Picade HAT itself. Actually the only reason for disabling the analog audio is because RetroPie wont let you select digital out otherwise, and has to be forced to use it. If you’re using another OS then this may not be a problem at all.

I think those are the key differences, anyway.


#3

Great! Thanks so much for your reply. I went ahead and ordered the HAT. I appreciate the help.


#4

Just a word of warning: the HAT installer will disable analog audio by default, but you can re-enable it by either removing dtparam=audio=off or making sure dtparam=audio=on is not commented out in /boot/config.txt.


#5

Thanks for the tip! I was worried it was going to be more complex than a simple change in the config file.