Headphone jack not working


#1

The headphone jack of my “old” Picade does not seem to work properly.

First, when I connect the headphones, the speakers are not mutted. The only option is to manually lower the volume of the speakers until zero. In any case, the volume of the headphones stays quite low in most games, and cannot be adjusted via de volume keys (they only change the volume of the speakers that sound at the same time). This happens regardless the headphone type (iem, full size, etc.).

But the weirdest thing is that, when using the headphones, I can only hear some audio channels of the soundtrack. For example, in Sonic I can hear the cymbals of the music, but not the SFX or the beats of the soundtrack… In other games/emulators, it happens the other way around (I hear some sound effects but not the music). The missing sounds/channels are there, but in an almost inaudible volume. This is really weird…

I’ve checked the headphone socket in the PCB and looks ok (no lose connections). On the other hand, the sound via the speakers is perfect in all cases.

I tried the different PCB firmwares available, and the problem persists. Moreover the “experimental” firmware causes the buttons to stop working and the speakers to output hiss and static sounds.

Any ideas?

Thanks


#2

Headphone jack on the Pi?


#3

I ment the headphone jack of the “old” Picade PCB. The headphone jack of the Pi is working fine, since it feeds the audio input of the Picade PCB and the sound via the speakers is fine. It seems to be the routing of this signal to the headphone out of the Picade what is not working properly.


#4

Ok, I don’t have that hardware so I can’t help much more.


#5

This is unusual since the two jacks on the Picade PCB are effectively directly connected- do the same headphones work if they are connected directly to the Pi’s output?

What kind of jack is it on your headphones? Do they include a microphone?


#6

No, they are regular headphone with 3 pole TRS jacks. I tried different headphones anyway, with the same result. I’ve also tried to connect the headphones directly to the 3.5mm output of the Pi and they work fine, so there is something wrong with the routing through the Picade PCB to the external headphone output. It is very strange if the output is just a bypass of the audio input. If it was a matter of stereo to mono sound I may undertand that a lose connection of the external hedphone output may cause it but this “partial” sound effects thing is very weird…


#7

I’ve created two short videos showing the problem.

In the first one, the sound is coming from the Picade speakers. Both the soundtrack and the SFX (Sonic jumping sound) work:

https://www.dropbox.com/s/qua6uqksy77gwvo/Picade%20speakers.mp4?dl=0

In the second one I attached a external speaker to the headphone output of the Picade (and mutted the Picade speakers). Now the soundtrack works but not the SFX (no Sonic jump sound).

https://www.dropbox.com/s/kgfcrgdrhti5no2/External%20speakers%20via%20headphone%20output.mp4?dl=0

In other games, neither the SFX and the soundtrack work, or the later partially works (no drums). I seems like only the sounds that are synthetized (not digitalized) are working through the headphone output. As I detailed above, if I connect the external speaker or the headphones directly to the Raspberry’s 3.5mm audio output, everything works ok.

Could this be a faulty PCB?


#8

The only rational explanation I can think of is that you’re missing an audio channel (L/R) when the external speakers are connected.- but it would make no sense for game SFX/music to be played on different channels.

Is this a Kickstarter Picade PCB or the newer retail one?


#9

Yes, this is what I though at the begining. I double checked that the jack is properly inserted and also tried different headphones with the same result. The PCB is the retail one (bought two months ago, the issue was present from the begining). Maybe the schematic of the PCB could help to understand the connections between the audio input and output?

Thanks