How to disable Hyperpixel?


#1

My hyperpixel is too dark to be readable and has dead pixels (see post “HYPERPIXEL - Dead Pixels on Display”). How do I disable it so I can be back to an HDMI output? Simply removing it doesn’t make it. Can this be done directly from within the SD card (I currently have no display, and can’t ssh)?


#2

Yes, just comment out or delete the lines relating to hyperpixel in /boot/config.txt (or config.txt in the boot partition when mounted on a host computer)

You should see them titled with # HyperPixel LCD Settings

And the # character preceding any line turns that line into a comment, effectively disabling it.


#3

Thanks! I’ve deleted the lines altogether (including the last one referring to GPIO backlight).

But is there anything else that was set by the Hyperpixel install script (from gihub, the auto install)? Because now while I do have the HDMI back, it loads slower than before installing the Hyperpixel script and with a temporary white rectangle at the top (just before the menu bar appears).
Nothing critical though :)


#4

hyerpixel-init and hyperpixel-touch are probably still running. You can disable those with sudo systemctl disable hyperpixel-init and sudo systemctl disable hyperpixel-touch if I remember correctly.