Hyperpixel - nothing on screen after reboot for Pi3 & fresh Raspbian


#1

I wanted to include my new hyperpixel on my Pi3. I flashed a fresh Raspbian, did a apt-get update and apt-get dist-upgrade. I seated the hyperpixel (I do not think I pressed very hard) I downloaded the hyperepixel software from GitHub and run the script and it reported success. When I rebooted I could see a glow around the edges of the hyperpixel but no words/images. I plugged in a monitor via the hdmi and that was also blank (but if I restored the original /boot/configure file I can use an external monitor).
I looked in the /boot/configure file and that looks like the examples given. The other files mentioned in the manual setup are where they should be an are executable.
So my questions:
a) with the boot file set to invoke the hyperpixel I can’t see the startup sequence so no idea about debug
b) is there a way short of switching boot/configure files to switch between hyper pixel and an external monitor?
c) is there a command I can give from a ssh connection that would make the hyper pixel live?
d) is nothing-in-the-display a sympton of ‘pressing-to-hard-during-placement’?
e) might there be something that recently changed in Raspbian to cause it not to work? If so what should I look for? Should I try a different distribution?
-Jon


#2

I almost suggested using Serial here, but obviously that’s impossible since those pins are taken by HyperPixel itsef! Yes, this is a tricky one! Sometimes you can see issues by running dmesg after the system has booted- assuming it’s booted.

Not a simple way, but people have discussed techniques on this forum. Since the config is one of the first things the Pi loads on boot, that involves swapping the config file (using a menu either after, or early in the boot process) and rebooting.

It’s worth trying hyperpixel-init and seeing if that works. It’s possible it’s not being run at startup.

Not that I’ve seen so far. And I suspect that’s unlikely to be the cause.

Possible, but unlikely. I don’t think there have been any major updates since we launched HyperPixel.

I think your best bet is to SSH in and try hyperpixel-init, it might be that the scripts to run HyperPixel aren’t being launched on startup.


#3

Further the idea of using dames on the Pi3. Here are some of the lines that seem to be related…
pi@raspberry-hyper:~ $ dmesg
[ 0.000000] Booting Linux on physical CPU 0xf00
[ 0.000000] Linux version 4.9.35-v7+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #1014 SMP Fri Jun 30 14:47:43 BST 2017
[ 0.000000] CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d
[ 0.000000] CPU: div instructions available: patching division code
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ 0.000000] OF: fdt:Machine model: Raspberry Pi 2 Model B Rev 1.1
. . .
[ 0.000382] Console: colour dummy device 80x30
[ 0.001352] console [tty1] enabled
[ 0.001408] Calibrating delay loop (skipped), value calculated using timer frequency… 38.40 BogoMIPS (lpj=192000)
. . .
[ 0.294822] io scheduler cfq registered
[ 0.300641] BCM2708FB: allocated DMA memory fb900000
[ 0.300719] BCM2708FB: allocated DMA channel 0 @ bc80f000
[ 0.300928] raspberrypi-firmware soc:firmware: Request 0x00048003 returned status 0x80000001
[ 0.300991] bcm2708_fb soc:fb: Failed to allocate GPU framebuffer (-22)
[ 0.301051] bcm2708_fb soc:fb: probe failed, err -22
[ 0.301105] bcm2708_fb: probe of soc:fb failed with error -22
[ 0.303611] bcm2835-rng 3f104000.rng: hwrng registered
[ 0.303772] vc-cma: Videocore CMA driver
[ 0.303809] vc-cma: vc_cma_base = 0x00000000
[ 0.303841] vc-cma: vc_cma_size = 0x00000000 (0 MiB)
[ 0.303873] vc-cma: vc_cma_initial = 0x00000000 (0 MiB)
[ 0.304147] vc-mem: phys_addr:0x00000000 mem_base=0x3dc00000 mem_size:0x3f000000(1008 MiB)
. . .
[ 6.535539] usbcore: registered new interface driver rt2800usb
[ 7.045554] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file ‘rt2870.bin’
[ 7.049171] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
[ 7.117199] input: Touchscreen as /devices/virtual/input/input3
[ 7.370438] random: crng init done
[ . . .

Any of this give clues.

I tried to manually issue the hyper pixel-init command. No messages back after that command and no change in the display. -Jon


#4

I have similar problem, check with phone LED maybe you have text on display, but no backlight? (like me :()


#5

I can see light around the edge of the screen.

From the discussion I am wondering if there is one of the other RasPi configuration options for the GPIO pins or another library that did not get set or invoked?


#6

you are lucky, your backlight is working then…


#7

Could something else be firing up and taking over a pin needed by the display? Usually this results in weird discoloration or visible distortion of the image, but I suspect it’s possible it could result in a blank display. Did you have anything set up on the same Pi before HyperPixel? Could you post your /boot/config.txt, use code formatting:

```
like so
```

#8

The RasPi was flashed with the latest Raspbian. I did an apt-get update, apt-get dist-upgrade
and the downloaded the git contents as per directions.

Here is the contents of the config.txt file. I hope this gives you ideas. -Jon

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=31

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem=48
core_freq=500
sdram_freq=500
over_voltage=2

# HyperPixel LCD Settings
dtoverlay=hyperpixel
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0
framebuffer_width=800
framebuffer_height=480
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x6f016
display_rotate=2
hdmi_timings=800 0 50 20 50 480 1 3 2 3 0 0 0 60 0 32000000 6

# Use a basic GPIO backlight driver with on/off support
dtoverlay=hyperpixel-gpio-backlight

#9

Hmm, all looks right. Although you might want to try commenting out to eliminate them from the equation:

gpu_mem=48
core_freq=500
sdram_freq=500
over_voltage=2

What about:

cat /etc/os-release

And:

ls /dev/i2c*

#10

Here is what I get for the commands you requested…

I reflashed Raspbian, did apt-get update, apt-get upgrade (the prior setup used apt-get dist-upgrade.
I used ras-config to check that I2C and SPI
are disabled. I am writing this just before I reboot.

pi@raspberrypi:~ cat /etc/os-release PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs" pi@raspberrypi:~

pi@raspberrypi:~ $ ls /dev/i2c*
ls: cannot access /dev/i2c*: No such file or directory

I then did the reboot and the hyperpixel is working! Which of the re-flash, running
the pi configuration tool and turning off the interfaces helped is unknown.

Seems like it would be good to update the documentation to suggest if folk are using
Raspbian they ensue they do the apt-get update and apt-get upgrade and use the
configuration tool to double check the interfaces if they have any trouble.

Thanks for your help!


#11

I agree, and I’ve made a note of this in our shared TODO.

As much as I say “if it ain’t broke, don’t fix it”, staying up to date is a good thing.


#12

I had the same issue, and after trying all of the above, the it was only fixed by running:

sudo rpi-update

Which makes sense, I suppose!


#13

This should almost never make a difference, since “rpi-update” just installs an unstable pre-release of the Pi kernel which usually causes more problems than it solves. Just using apt to update to the newest stable kernel should suffice.

How old was your SD card? I can only guess that the kernel was held back when doing an upgrade.

You can normally get back on track with:

sudo apt-get update
sudo apt-get install --reinstall libraspberrypi0 libraspberrypi-{bin,dev,doc} raspberrypi-bootloader
sudo reboot

#14

I have a similar problem - just got a Hyperpixel, trying it on a Raspberry Pi 2 Model B with updated Raspbian Jesse. No image at all, backlight working, LCD dark, nothing on HDMI screen after initial boot colours. Pi is working as I can SSH into it ok. I did not try a clean Raspbian install yet - so is there a way I can disable the Hyperpixel so I can use the HDMI output to easily back up files before I reformat the SD card?


#15

Update - my HyperPixel is working after a clean install of Raspbian Jessie. Am building a touch-screen internet radio first, an excuse to get to grips with tkinter finally…


#16

Hi guys,

I’m having the same issues with a brand new Hyperpixel 4 installed on a Pi Zero W with a fresh install of Raspbian. I’ve tried to go through all the responses above but still getting nothing on my screen. The Hyperpixel is lighting up the backlight but I’m getting nothing else.

My boot config file is as follows:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=off
#dtparam=i2s=on
dtparam=spi=off

# Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

dtparam=audio=on

# NOOBS Auto-generated Settings:

#hdmi_force_hotplug=1

overscan_left=0

overscan_right=0

overscan_top=0

overscan_bottom=0

framebuffer_width=800

framebuffer_height=480

enable_dpi_lcd=1

display_default_lcd=1

dpi_group=2

dpi_mode=87

dpi_output_format=0x7f216

display_rotate=3

hdmi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6

# HyperPixel LCD Settings

dtoverlay=hyperpixel

overscan_left=0

overscan_right=0

overscan_top=0

overscan_bottom=0

framebuffer_width=800

framebuffer_height=480

enable_dpi_lcd=1

display_default_lcd=1

dpi_group=2

dpi_mode=87

dpi_output_format=0x6f016

display_rotate=2

hdmi_timings=800 0 50 20 50 480 1 3 2 3 0 0 0 60 0 32000000 6

# Use a basic GPIO backlight driver with on/off support

dtoverlay=hyperpixel-gpio-backlight

dtoverlay=hyperpixel4

Thank you for any help in advance!


#17

It looks like you’ve got a pretty messy mix of both Hyperpixel 1 and Hyperpixel 2 settings there, you should probably:

  1. Uninstall Hyperpixel 4 using the uninstaller
  2. Uninstall Hyperpixel by running:
    a. sudo systemctl disable hyperpixel-init
    b. sudo systemctl disable hyperpixel-touch
  3. Restore your /boot/config.txt to the default, available here: https://raw.githubusercontent.com/RPi-Distro/pi-gen/589afcc72d9a9e514f499af5530da74577cd46c6/stage1/00-boot-files/files/config.txt
  4. Reinstall Hyperpixel 4 using the installer

#18

Hi @gadgetoid,

Thank you so much for the help and quick reply. I’ve made all the updates but I’m still getting a black back-lit screen. My config.txt file is now as below. Any thoughts? I’m wondering whether it might be something to do with my SPI or CPI setup, although I have disabled both these options in my raspi-config…

# For more options and information see

# http://rpf.io/configtxt

# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible

# and your display can output without overscan

#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console

# goes off screen, and negative if there is too much border

#overscan_left=16

#overscan_right=16

#overscan_top=16

#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus

# overscan.

#framebuffer_width=1280

#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1

#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in

# DMT (computer monitor) modes

#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or

# no display

#config_hdmi_boost=4

# uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.

#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on

#dtparam=i2s=on

#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

dtparam=audio=on

dtoverlay=hyperpixel4

overscan_left=0

overscan_right=0

overscan_top=0

overscan_bottom=0

framebuffer_width=800

framebuffer_height=480

enable_dpi_lcd=1

display_default_lcd=1

dpi_group=2

dpi_mode=87

dpi_output_format=0x7f216

display_rotate=3

hdmi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6

#19

I would guess something else is running on your Pi that’s interfering with the setup, or perhaps “hyperpixel4-init” is not working. Can you SSH in and try running it manually?

Might’ve worth starting from a fresh Raspbian install if you can’t get to the bottom of it.


#20

Hi @gadgetoid,

Thanks for your help. I managed to track it down to an issue with one of the pins - all is now fixed and the hyperpixel is working perfectly. Thanks!