Hyperpixel4 install failed to fetch

Hi, we recently purchased a hyperpixel4 and connected to a RPI 3. It always seems to fail to fetch some indexes and the screen stays blank.

pi@raspberrypi:~ $ curl -sSL https://get.pimoroni.com/hyperpixel4 | bash

This script will install everything needed to use
HyperPixel4

Always be careful when running scripts and commands copied
from the internet. Ensure they are from a trusted source.

If you want to see what this script does before running it,
you should run: ‘curl https://get.pimoroni.com/hyperpixel4

Do you wish to continue? [y/N] y

Pick your HyperPixel 4 and Raspberry Pi combo below:
0 : Rectangular - Pi 3B+ or older
1 : Rectangular - Pi 4 / Pi 400
2 : Rectangular - Pi 4 / Pi 400 - Experimental Touch Fix
3 : Weirdly Square - Pi 3B+ or older
4 : Weirdly Square - Pi 4 / Pi 400
Press Ctrl+C to cancel.

If you have problems with your install
let us know: https colon //github dot com/pimoroni/hyperpixel4

Enter an option [0-4]: 3

When did you purchase your HyperPixel Square?
0: 2021 or later
1: 2020 or earlier
Press Ctrl+C to cancel.

If you’re unsure, don’t worry, you can change your /boot/config.txt later.

Enter an option [0-1]: 0

Installing Weirdly Square for Pi 3B+ or older
for HP manufactured 2021 or later.
Is this correct? [y/N] y
Using git branch: square-2021

Checking environment…
Updating apt indexes…
…W: Failed to fetch
http colon //mirrordirector Dot raspbian dot org/raspbian/dists/jessie/main/binary-armhf/Packages
404 Not Found [IP: 93.93.128.193 80]

W: Failed to fetch
http colon //mirrordirector dot raspbian dot org/raspbian/dists/jessie/contrib/binary-armhf/Packages
404 Not Found [IP: 93.93.128.193 80]

W: Failed to fetch
http:/colon mirrordirector dot raspbian dot org/raspbian/dists/jessie/non-free/binary-armhf/Packages
404 Not Found [IP: 93.93.128.193 80]

W: Failed to fetch
http colon //mirrordirector dot raspbian dot org/raspbian/dists/jessie/rpi/binary-armhf/Packages
404 Not Found [IP: 93.93.128.193 80]

E: Some index files failed to download. They have been ignored, or old
ones used instead.
Apt failed to update indexes!
pi@raspberrypi:~ $ …
pi@raspberrypi:~ $

Are you running Jessie?

Hi, yes it appears so.

Revision : a02082
Description: Raspbian GNU/Linux 8.0 (jessie)
4.1.18-v7+

Also, I logged issue 44 to GitHub and logged the full boot config. I have turned on all interfaces now but still no luck.

If you install the latest Pi OS the Hyperpixel installer will likely work. Jessie has likely been depreciated by the Pi Foundation and is missing things that are in Buster.

Ok, thanks will look into this and report back in a few days.

I believe you can run apt-get dist-upgrade and not have to reinstall?

HI, thanks for the tips. I did try to upgrade the RPi3 using apt-get but there was a lot of issues. In the end reverted to doing a new image on the SD card.

So now the command curl -sSL https://get.pimoroni.com/hyperpixel4 | bash works fine - I selected option 3 and 0.

On reboot however, I now only get a multicolour screen. There was a message that the power supply voltage was low so possibly the mains adaptor or USB cable are not up to the job. Any hints on what to do next?

What are you using for a power supply?
IMHO the official Pi Foundation supply is the way to go.

I went down to Jaycar (local Aust electronics store) and bought a Pi power supply - 5.1V and 2.5A.

I tried again and everything worked until the reboot where the screen changes to multicolour and nothing else happens - even after a day of leaving the power on.

I have a Pi Zero coming soon so will try that.

As long as that’s an actual “Power Supply” and not a “Charger”, I would think it should be OK.
I don’t own a Hyperpixel, just so you know. Kind or sounds like you might be picking the wrong options? That or the install instructions are wrong?
5:30 AM here, and I haven’t looked at the instructions. I will in a bit though, time for my morning walk in the woods with my dog Missy.

EDIT: Had a look see, not much to see really. I’d have to have one and run the installer to see what the options are. I’m guessing it s asking you if its a Hyperpixel or Hyperpixel 4, and if its square etc?

HI, yes, there are 5 options - 0 to 4. First two options are Rpi3 rectangular or Rpi4 rectangular. Then there are 3 square options.

The next option is 2021 or 2020 model.

I selected option 3 for Rpi3 square and then option 0 for 2021. I can go through again - just a bit of a pain to reprogram the SD card each time - takes around ten minutes.

There is likely an install.sh file that calls up that setup routine. Do you lose your HDMI monitor? If no find the install.sh and run it.
From the directory its in run
sudo ./install.sh
Even better is if you can find that setup file for the options and just run it.

Thanks for the tips. I have tried all options now. Option 3 resets and then the display just shows the multi-colour option.

Option 0 - rectangular for RPi3 just shows a black screen. I am using a RPi 3B dated 2015.

I am not sure how to run any install program when the display has hung or crashed. Before resetting, I can try this but would it make any difference?

I have a few PiZeros arriving soon so will try them. Looks like the software does not really work on older RPis.

Somethings not right that’s for sure.
@hel

The installer should work with older Pis.

What kind of Hyperpixel do you have? Can you send a photo showing the multi-colour screen?

Graphical weirdness with Hyperpixel can happen when you’ve got something else connected to (or trying to use) the Pi’s GPIO, might be worth checking if that’s the case?