How to get headphones working?

I’m trying to switch over to using headphones in order to not annoy my wife at night time - please help this is a life or death situation. Ideally I’d like to be able to switch between the picade speaker and headphones via the menu but have failed to find such an option thus far.

I have a 10" Picade from last year with a Raspberry Pi 4 in it (Picade HAT I have is pictured below). I have audio working out of the speaker fine and can change the volume up and down (I wasn’t able to at first). The version of Retropie is 4.7.1 running on Buster with Emulation Station V2.9.6RP (all standard stuff of 4.7.1 I believe).

My sound settings in the main menu are: System Volume: 60%, Audio Card: Default, Audio Device: PCM, …, …, OMX Player Audio Device: Alsa. I have the headphones plugged into the Pi 4’s 3.5mm headphone jack and the picade speaker is attached to the Picade HAT. The Raspi-config audio settings do not work as presumably the Picade HATs audio drivers are used instead. I dont have an /home/pi/.asoundrc file that I’ve seen mentioned.

When I plug in my headphones I can hear the splash video through them and not the internal picade speaker. Once in emulation station proper the roles are reversed and I can hear all the sound come out of the internal speaker and not the headphones. I’m guessing this is because of the Picade HAT driver has been loaded in and switched over to.

From what I’ve read on the forums I gather I can change my \boot\config.txt to turn off the standard raspberry pi audio driver and use the Picade HAT’s audio driver with: dtparam=audio=off/on and (more pertinent to this question) vice versa. This is rather cumbersome, due to having to have a keyboard attached to the Picade or a PC connected and then enter a load of commands off the top of my head and a reboot. Surely there is a more direct route?

Anyway any help would be greatly appreciated.


The wrinkle is that to use the Picade Hat Speaker, the default audio source has to be switched to use i2s via the GPIO header, which then uses the DAC on the Picade Hat.
Picade X HAT at Raspberry Pi GPIO Pinout

As far as I know there is no easy way to switch back and forth. As you have found out, its a config.txt edit and reboot.

Boo! Thank you very much for your helpful reply though.

Maybe one day the Pimoroni chaps can release a Picade X HAT with a headphone jack on it.