HyperPixel4 Touch is not working

Hi, I recently got a HyperPixel 4 Touch Version.
I used it with an older Pi before and it worked nicely. The old pi was to slow so i baught a Pi 4 (running the latest Raspian buster) and put the display on it. But now the display wont recognize touch at all.

For Installation I used:
curl https://get.pimoroni.com/hyperpixel4 | bash
Like instructed on https://learn.pimoroni.com/tutorial/sandyj/getting-started-with-hyperpixel-4

Any ideas how to Activate Touch input?

Same problem here. I installed Raspian buster latest version on Pi 4, then installed the driver (tried both curl install and manual install from github). Right after the driver is installed all seems to work well, the screen works, touch works. Then I use e.g. Chromium and suddenly Touch won’t work anymore. Even after a reboot Touch doesn’t work anymore. Only when I start all over again, installing from scratch, I can get it to work for a while again. Also tried updating the OS before installing the screen driver, exactly the same happens…

Update, if I don’t use Chromium it doesn’t happen… Weird.

Chromium or not, touch just doesn’t work at all

Last night I switched my Raspi off and unplugged the power supply. This morning I booted up and the display works!!
I haven’t changed a thing though. I didn’t do any updates or software changes. The power supply and the USB cable are also the same I used when the display didn’t work.
It’s really weird.

Edit: it just came to me that I unplugged A Bluetooth and a WiFi USB Stick yesterday. Maybe my power supply wasn’t sufficient enough to support all these devices. The Pi 4 is a bit more power hungry after all.

A little update on my side here: The display worked during the day. I just had to restart my Raspi and now the touch input is gone again. I’m clueless here guys!

This is a temperature-sensitive race condition that’s documented here- https://github.com/pimoroni/hyperpixel4/issues/41#issuecomment-549759417

I should probably push the fixed installer live to avoid others coming across the same issue.