Inky pHAT compatibility issues with Raspberry Pi 4B

Hey everyone,

I’ve bought a Raspberry Pi Model 4B for a few different projects, one of which is to use an Inky pHAT display on it.

When the display arrived, I attached it to the Pi’s GPIO pins (yes, the right way around) and followed the tutorials on GitHub and the Getting Started blog entry. All the installation steps were successful.

But when running the example scripts, they would always get stuck on the Inky’s show() function, even though I did wait longer than a refresh would take. At first I thought the display or its board were broken but after trying it on an old Raspberry Pi 1 B+ and a Pi 3B (see image) it worked fine out-of-the-box while also using the exact same Raspbian installation (simply switching the SD card). I also went through all the configuration steps again on all devices.

Does anyone here know about any problems with the Inky pHAT or similar §HAT devices due to changes in the hardware from the Raspberry Pi 3 to 4 which could be causing my problem? Any help would be greatly appreciated. Thanks in advance!

PS: I’ve asked the same question on the Raspberry Pi StackExchange yesterday:

Welcome!

I’ve seen it mentioned here several times that the current Raspbian isn’t 100% compatible with the Pi4. So things may run fie on the B+ but not on the 4.I don’t have more details but you seem to have found one incompatibility.

1 Like

Hi @Crowbot,

thanks for your reply! So you’re suggesting it’s basically a problem with Raspbian which might be solved with future updates?

The only roughly similar thing I found on here was this post by olly. But in my case, the installation did not cause any problems…

The thrust of what I read was that, given the hardware changes in the Pi 4, some things in Raspbian didn’t click. We all expect that someday these issues will be fixed. There may need to be a board specific version of Raspbian.

1 Like