Inky pHAT not being detected


I got an Inky pHAT a few years ago from the Pimoroni stand at a Cambridge Raspberry Pi event (iirc), and I can remember that it worked initially, however it has sat in a drawer for a few years now, and every time I’ve got it out tried using it in that time, I’ve never been able to get it to work again, and today I tried again on the latest Raspbian version (11, Bullseye), running the installer script:

curl | bash

and choosing to install all the dependencies for the examples too.

I tried running the example script, which results in the following output saying that a board could not be found:

Specifying the --type and --colour flags cause the script to shows the messages as if it was working, but the HAT attached to the pi does not change at all:

Here’s some pictures of the pHAT attached to my Pi Zero W (I have also tried it with other Pis and it still isn’t detected):

And the back of the pHAT, in case that’s important:

The pHAT is pushed down onto the Pi as far as it will go (I checked this with a single jumper lead, which also does not go any deeper than the Pi’s header, and leaves a bit of metal visible too), and the flat cable to the display is also fully in its connector.

I assume this might be a hardware failure of some sort, but I can’t see anything visibly damaged on the back, although I assume there are other components on the top of the board, under the display, that I can’t see, and I just wanted to see if anyone else had any ideas about what might be happening

i2c and SPI enabled?

Yep! raspi-config showed both as enabled, and they are both visible in /dev:

Ok, that’s all I have at the moment. I don’t own an Inky of any type.