Is It Possible To Overcook A Pi (yes, it is)?



I have a pre-soldered Pi ZeroW plugged into a pHATStack and powered by an official power supply.

The Pi is also connected to the computer via a piUART cable which again provides power.

This means that I can connect to it in a few different ways:

  • via SSH (with authentication keys).
  • Using VNC, avoiding the SSH authentication.
  • via the cable for when I tinker and break something network related (it happens a lot).

This is essentially my test rig and as such the OS is always up to date and the SD card has all of the necessary libraries and permissions needed.

The other night I left it all plugged in and closed the laptop lid, effectively putting the machine into ‘Suspend’ mode.

This meant that the Pi was powered by 2 sources; the official power supply, and power coming through the piUART cable.

I woke up to a dead Pi** and a fried motherboard***.

** / ***

** Yes, I have been through every possible test to see if the Pi is dead. It is.

*** Yes, the motherboard is fried, it has been disassembled, the immediately obvious blown components identified, and the board replaced.

My questions are:

  • How is this even possible?
  • Has there been some sort of weird power feedback from the Pi back in to the computer causing this?
  • Is there any way of perforning an autopsy on the Zero? (@gadgetoid Do you want me to send this back so you can slice it open?)

This only happened since using the piUART cable, everything worked fine before introducing it into the testing setup.

I’m kind of nervous now about plugging the UART cable back in, as I don’t want to blow up a brand new Chromebook!

Any thoughts or insights greatly appreciated.



It’s not a good idea to feed to different power sources in. If they are not the exact same voltage one will sink current from the other. They will fight each other for the load. The power switch on the PiUart should have been off if the Pi was being powered by its own power supply. As far as I know the on off switch only removes the +5V coming in the USB cable. The Uart will still work with the switch off. I have that PiUart, but haven’t used it in a long time. Going by memory and whats listed on the Adafuit product page.
I’d turn the power switch on the PiUart off if using a seperat power supply with the Pi.
Or just feed power in via the Pi Uart. Unplug the Pi power supply.


Hi, and thanks for replying.

What you say makes complete sense.

I kind of guessed that the two power thing was the culprit, I just wish I’d thought about it sooner.

Bit of an expensive lesson !

At least I’ll remember in the future…




My background is in electronics, so its knowledge I learned over the years.
Something like this won’t be obvious to a lot of people.

Most PC’s have a USB protection circuit to prevent an overcurrent.
It’s called a crowbar circuit. Once its tripped you have to remove all power from the USB bus to clear it.
Power down the PC and then unplug the power supply from the wall outlet.
Remove the battery if its a laptop etc. Then press the power button and hold it for 5 seconds or so.
The power led should light up and then fade to black.
Then plug the power in and see if you have working USB ports again.

Other than the PI Zero, all other PI models have a poly fuse that will open circuit if too much current flows.
They are self healing over time. Once they cool down again the Pi should be good to go again.
This only works though if power is being fed in via the Micro USB port.
If you power VIA the GPIO pin it by passes the poly fuse and all bets are off.


There is a product video here, They don’t give much more info than what’s in the product description though? I also noticed a switch enable jumper on the bottom side of the board, no mention of what its for though? I’m guessing if you cut that the on off switch is permanently off regardless of its actual physical position.
If you do any more tinkering with it, could you confirm for me that it works even with the switch in the off position. To be honest that was a bit of an assumption on my part.



Yeah, I had the Chromebook in bits straight away.
(I had previously attacked it with a screwdriver to remove the Write Protection so that I could put a proper OS onto it.)

Power off, battery out, depress the power button, did it all, there was just no juice getting in.

It was only once it had been taken apart that the damage became obvious.

I’ll remember the bit about Poly Fuses though, I never knew that, it’s good to know.




Ha, I knew about the switch, I just never gave it a lot of thought !

I don’t think I’m going to start cutting jumpers, I’ll stick to either remembering or putting some electrical tape over the physical switch…

Next time I have a tinker (probably this weekend) I’ll report back.




Did you have to do anything fancy to get your PiUART to work? I had to edit a file and change a baud rate or something to get mine to work. That was a year or so ago. I may dig mine out and have another go at setting it up. I’ll post back my results too.


My enable switch jumper is open, not shorted, and my switch does not work. Switching it to ON does nothing.
The PiUart works just fine this way though, with power going to the Pi via the Micro USB power port.
I don’t remeber cutting that jumper, but maybe I did? I’ll have to have a look with a magnifying glass to tell for sure.
I followed the guide for connecting with Putty from Windows and had no problems logging in. I did have to change the baud rate. I don’t remeber it being so easy the first time around? I’m thinking they updated the tutorial.
I had to download and manually install the Windows 10 driver for the Uart. CP what ever it is. It was detected OK in device manager but had a yellow triangle with a !. Windows update could not find a driver so I did it manually. I’m running Windows 10 Enterprise LTSC 2019 on the laptop I used to test it with. .

EDIT: It looks like I cut my jumper, likely so I wouldn’t accidentally do what you did. It was so long ago that I last used it I can’t even remeber what Pi Project I wanted it for? Or why I didn’t use it?


hmm, from memory, no, nothing fancy.

From my Linux box it was a:

Plug it in.
sudo screen /dev/ttyUSB0 115200
Desktop appeared on the Chromebook screen.

I’ll double check though as that was the computer I fried.

My new one hasn’t had the pleasure of being introduced to the piUART yet, so it’ll be completely fresh process.




I can’t remeber now, how or what I had tried originally? I can’t remeber if it was a from Windows PC or another Pi? I started a thread on it on the Raspberry Pi forum, and I believe one on the Adafruit forum. I do remeber I had a hard time getting it to work / connect. I’ll go see if I can find either of those threads.

EDIT: Found the Adafruit thread I started, looks like its fixed by default now?

EDIT:2 Can’t find the Pi forum post, I think that was about the boot delay issue my original edit caused?

Best guess is what ever issue plagued me first time around has been fixed?



So, I can confirm that the switch cuts power to the board when in the ‘off’ position.

I can’t verify at the moment that you can still communicate with the Pi using this cable as I currently cannot connect.

I’m not sure if I fried that board too, as lsusb will not even show a connected device and dmesg is telling me that it cannot connect to USB.
(I’m not ruling the brand new Chromebook and USB-C out of this equation.)

I’ve ordered another known working one to check, and will report back.




Hope you get it all working OK this time around. Mines all unplugged and put away at the moment. Moved on to other things.


Just a quick reply to state that, yes, I burnt the piUART too.

So, that’s:

  • 1 x motherboard
  • 1 x Pi Zero
  • 1 x piUART

I’ll remember not to do that again !

This thread can be marked as closed now.




I’ve let the magic blue smoke out of a Pi Zero W. Plugged it in one row off on the GPIO. I was feeding my +5V in via the GPIO pins so it went where it shouldn’t. In the i2c pins I think. It wouldn’t boot up after that. So far near as I can remeber thats all I’ve smoked so far.
Mistakes happen, it sucks but it happens. =(



Luckily, I’ve never destroyed too much stuff.

That week was the outstanding exception for some reason.

(I also managed to solder the headers on a couple of button shims upside down; I mangled one in a terrible de-soldering attempt and put the other back in the cupboard.)


I’ve had a few instances where I had wished I had soldered on a different header. I know better than to try and unsolder 40 pins with what I have here at home though. It was easier to just add another Pi Zero to my next order with the header I want to use with it. I add a Pi Zero to just about every order even if I don’t need one. Its nice to have spares with no header already attached.

closed #18