Is there a way around no internet connection for dock to work


Installed latest version of Flotilla and updated firmware on the dock on six raspberry pi’s in preparation for a workshop

Unfortunately when trying to run workshop we found that the dock couldn’t be found in Rockpool unless connected to the internet.

Is there a way around this as we have to run workshops in places without internet connection.



There’s no way for discovery to work without an internet connection, since there’s just no sane way of auto-detecting things over the local network. However you should be able to connect to the dock manually using the “loopback” IP address: “”

Actually the local dock should be found in the event that remote discovery fails, and I think we fixed some bugs to this end recently, but it’s not in the offline installer yet. I’ll look into it.



Unfortunately the local dock isn’t found. And doesn’t find it either. I installed everything with curl -sS | bash yesterday and updated firmware as well. Is there a fix we can use as have another 2 workshops tomorrow.



Grab the latest Rockpool from here:

( hit Clone or Download then Download Zip )

And use that instead.

You shouldn’t need to specify the port when searching for local docks, but the fixed version linked above should, fingers crossed, just work.


I was going to post the same question and came across this thread.
I recently downloaded the latest release of software and firmware and everything worked at home with an internet connection.
Took it all into school and even though connected to the internet nothing worked, I am guessing due to their firewall settings.

So I have followed the above post, but was not sure what to do next.

I extracted all the files into Downloads/flotilla-rockpool-edge

do i then

  1. copy all of the above files into Pimoroni/flotilla/flotilla-rockpool/rockpool and re-install

2) copy all of the above files into /opt/rockpool

I have tried killing rockpool and then in the Downloads/flot… folder and entered sudo python and that does not find the dock with no internet.




The method for auto-finding the dock requires an internet connection unfortunately. Offline you will have to manually add a dock and enter the Pi’s IP address.


Thanks for the quick response,

the problem is there is no where for me to enter an ip address.

When I run flotilla the browser opens and I have “input with a + on the left, modify in the centre, output on the right with a + and the anchor in the middle at the bottom”.
As the browser opens it looks like it attempts to open another box, (possibly the box to enter IP address) but nothing is displayed.

If I click on the anchor sign at the bottom and then the dock icon, nothing happens. So there is nowhere for me to enter an IP address.
The browser is pointing at

If I then close the browser, connect to the internet and restart flotilla I get a box with searching for docks displayed, with my dock listed. Also an option to find dock manually.

I can then connect to my dock, disconnect from the internet and it works.

So, as I am using a PI3, a work around for me would be to connect to the internet via my phone, find the dock and then disable wifi.




That sounds like the javascript is failing to run at all, which browser on the Pi are you using?

Can you right-click -> inspect element to bring up the developer tools then switch to the errors tab to see what errors it might be throwing?


I am using the supplied chromium on the PI and I ran apt-get update and upgrade a couple of weeks ago.

errors are
Failed to load resource: net::ERR_INTERNET_DISCONNECTED
Uncaught TypeError: rockpool.attempt_list[x].target.equals is not a function
Failed to load resource: the server responded with a status of 404 (File not found)




This one rings a bell. And would no-doubt be where everything comes crashing down.

Might be worth trying this branch:

And, if I remember correctly, extracting it to /opt/rockpool replacing the files there.


I think I have done what you suggested

extracted the files an copied them into /opt/rockpool instead of the files that were there.
still get exactly same error with no internet, it all works with internet re-connected.




Hmm, I’m not sure what’s going awry here. It might be worth opening up the index.html file and locating the line:


Which you should change to:


A quick test of the Retheme code running locally on my Pi in Chromium suggests it does what I expect with networking disabled.

Try extracting the retheme zip file to another folder, and just loading the index.html directly in Chromium using a file URL, like for example: