Issue with "sudo service flotillad stop"


#1

Sorry to keep posting questions about my setup, which is as follows:
Pi zero with Motephat and mote strips, flotilla dock with touch and light modules.
I want it to run my python program on boot up. I have used the crontab -e which worked ok until I added the flotilla dock.
I needed to install the flotilla software as per your one line install. Again no problems. But in order to run the python program I had to use the “sudo service flotilla stop”. Again no problems.
But I would need to incorporate this into the pi boot up somewhere. I tried adding it to the crontab file but that did not work. After searching I found an option to edit the “bashrc” file and I added the “sudo service…” command to that. That seems to work, although it has made boot up time much longer, but now its as if the crontab function does not work as now my python program does not autorun anymore.

So I am asking the experts how to stop the flotillad and autorun my python program at bootup…PROPERLY!


#2

You should probably just:

sudo service flotillad disable

or:

sudo systemctl disable flotillad

Which prevents the service running at boot altogether. You can always run the Flotilla daemon manually, or re-enable it if you need to.


#3

Once again you have sorted my problems. Do you do evening classes !!