KeyBow Lights up but no inputs


#1

KeyBow Lights up but no inputs.

Excited to get hacking with this but after building and installing, the keys light out with their pretty defualt pattern, but on testing in notepad there is no output to windows.

I’m using Windows 10 Home 64bit.

I missing something simple ?


#2

Exactly the same here! I have assembled and set up my Keybow without changing any of the defaults. The leds glow in a pretty pattern, but none of the keys seem to send anything.


#3

Update: I plugged it in a second time without changing anything, and this time it is working :-)


#4

Probably just a driver issue, i.e. the system taking a little while to recognise it the first time.


#5

hmm agree must have been a driver. although unplugging didn’t work but a restart did :s


#6

on Dec 21st I wrote
Keypad works OK in Linux - but problems with LEDs (separate post)

however on Dec 22

After finding that KeyBow only seems to use ‘default.png’ for lighting I started to create a bespoke layout file.
I created the file but could not get it to load - the keys did not work. I downloaded the latest firmware …0.0.2
and still no joy.
Changed it to use ‘boilerplate’ - worked OK so amended ‘boilerplate.lua’ with my changes and that worked.
Then made some adjustments to ‘boilerplate.lua’ and it was back to not working !!.

I’ve also had problems with 2 microSD going ‘read only’. One of which had my revised ‘boilerplate.lua’ on it, but it still works on the keyboard.


Kebow - changing layout files dynamically