Kodi controller


#1

Hi All

Has anyone had any luck getting the PiCade controller working with Kodi? It works fine with all my emulators, but I can’t get any life from it within Kodi at all, only the keyboard works.

Cheers
Simon


#2

Hello all. I am having the same issue as well. Any help would be greatly appreciated.


#3

what are you calling the Picade controller?

… both the Picade HAT and PCB should appear as HID devices with default keyboard bindings - those are not optimised for use with Kodi, but technically it is possible to modify them, if slightly involved.


#4

I was referring to the PCB. I’ve got the PiCade cabinet and the standard controller works perfectly with most emulators, but I just couldn’t get Kodi to see it.

Just a bit frustrating that whenever I fire up Kodi, I need to also grab for a keyboard when most of the stuff I want to play is just a few clicks away.

Thanks.


#5

the Picade should be registered by the system as a HID, that is in fact how it can be recognised by Emulation Station. What is the output of lsusb? What about (sudo) showkey?

… perhaps there just aren’t any active keycodes relevant to Kodi (although I would have expected navigation left and right to work, with the default firmware).


#6

Hi,
I’m a new picade owner and it’s my first post. I have the same issue here since I updated retropie and the picade firmware. Both of lsusb is showind arduino controlled and the inputs match perfectly the keyboard. My buttons work so far on all the emulator but for kodi it doesn’t work.
I tried to use the gamepad mode with picade config but still, kodi doesn’t decect. I mapped my steam controlled to the same keys as the one in the picade for default keyboard and the controller and the keyboard work but not the picade…

sudo lsusb
Bus 001 Device 008: ID 28de:1142
Bus 001 Device 010: ID 045e:028e Microsoft Corp. Xbox360 Controller
Bus 001 Device 009: ID 413c:2112 Dell Computer Corp.
Bus 001 Device 007: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 006: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 005: ID 2341:8036 Arduino SA Leonardo (CDC ACM, HID)
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo showkey
press any key (program terminates 10s after last keypress)…
keycode 108 press
keycode 108 release
keycode 105 press
keycode 105 release
keycode 103 press
keycode 103 release
keycode 106 press
keycode 106 release
keycode 29 press
keycode 29 release
keycode 56 press
keycode 56 release
keycode 57 press
keycode 57 release
keycode 57 press
keycode 57 release
keycode 42 press
keycode 42 release
keycode 44 press
keycode 44 release
keycode 45 press
keycode 45 release
keycode 31 press
keycode 31 release
keycode 46 press
keycode 46 release
keycode 1 press
keycode 1 release
keycode 28 press
keycode 28 release


#7

Does anybody face the same issues?
I tried to reflash the firmware but its still the same, the picade controller works pretty well with anything else on retropie, just with kodi…


#8

when you say reflash the firmware, have you used custom keybindings? This is explained here and I expect will be necessary.


#9

Still the same problem with Picade PCB (bought May 2017). Everything works fine (Retropie, Emus, Roms…) only KODI 17.3 does not recognize the PCB with attached Joystick and buttons.

  • PCB is the only USB device except the 8" screen.

  • Retropie 4.2 with Kodi 17.3 (last updated this week)

  • lsusb: `Bus 001 Device 004: ID 2341:8036 Arduino SA Leonardo (CDC ACM, HID)

  • sudo showkey = all buttons work f.a. “up” = 103, “down” = 108…

Why does Kodi not recoqnize the HID keyboard device? If I attach a usb keyboard it works just fine with Kodi.

Thanks