My PiHub is not working


#1

Hello,

I recently bought a PiHub (over Amazon) and it doesn’t seem to be working properly. Before I try and send it back to Amazon, I thought I’d try and see if the problem didn’t come from me plugging the PiHub poorly.

So after opening the box, I plugged the power on the PiHub and used and USB cable I had laying around to try and power the Pi. I plugged it in the bottom left plug, the one with the Raspberry logo behind it.
Then the Pi doesn’t power on.
I tried to see if my Pi was still working with another power supply, and it did work properly.

I decided to try the PiHub as a USB hub, and wasn’t able to see my external HDD through the PiHub on my computer (it did power up the HDD though).

There’s a photo of how I plugged it : http://imgur.com/11pzRGY

Is this issue common ?


#2

Ahoy!

First up, have you tried the PiHub on another computer to see if the problem is the same?

Could you take a photo of your setup with the hard drive connected, it might help.

It’s not a problem I’ve come across before, but this is actually the first time I’ve even heard of a PiHub problem so I’m probably not the best person to answer… but we can try some things and see how it goes!


#3

this is actually the first time I’ve even heard of a PiHub problem

That would explain why I couldn’t find any topic relating to issues with it online.

Here is a photo of my external HDD plugged into my computer through the PiHub.
The computer doesn’t recognize the HDD at first (I have to go through My Computer > Manage > Disk Manager for it to be shown. It then asks me to initialize the disk, but when I try and do that it says the disk is not ready – even though the disk works properly when plugged directly on my computer)


#4

Hey, I back with some new results. It seems my problem is coming from the power supply of the PiHub.
I made an imgur album that shows what works and what doesn’t. I guess the 2,1 mm jack adapter doesn’t function properly.

I’m going to ask Amazon for a refund, but I don’t know if I’m going to buy another PiHub or not; if the problem comes from the EU adapter that doesn’t work, I may have the same problem with a new product.


#5

That’s a sensible course of action- I’ve not heard of this problem before though so I’m going to guess you got a faulty PiHub or Adaptor and would recommend both are replaced.

It’s possible that we might want to take a look at it to see what the fault is- if that happens to be the case would you be happy to send it back and have us cover postage?

Thanks and I’m really sorry you got a dud!

  • edit, corrected PiBow to PiHub, must have had PiBows on the brain!

#6

Sure, I wouldn’t mind at all. I wonder however how the logistics would go; I know how to return the product to Amazon, but I don’t quite know how to do the same with you.
Let me know if ytou’re still interested, or I will have to send it back to Amazon before early December.