No display with LG Ultrawide

I have a Raspberry Pi 4 and it’s plugged into an ultrawide monitor because that’s the only monitor I have which has any HDMI ports. I know that the Pi doesn’t have a resolution option for 2560 * 1080 but I don’t think that would cause no display output, as I have previously managed to get a display output on this monitor.

I have tried the suggestions on the Raspberry Pi forums, such as setting the hdmi_hotplug option, but no dice. I still sometimes get no display output and the only solution (which is not ideal) seems to be to reboot the Pi. I have not tested with another monitor because I do not have another HDMI-capable monitor.

A TV that has HDMI in will work for testing.

What should I do if testing with another TV doesn’t work?

That I don’t know? What I do know is some monitors won’t display an image if the source is at a resolution it doesn’t support. You usually get an out of range etc message.

Well, it’s a 2560 * 1080 monitor and the resolution for the Pi I think is 1920 * 1080, so shouldn’t it work if the source is outputting a lower resolution than the destination? It works sometimes, but then drops out again and I have no idea why.

I would think that should work.
Have you tried a different HDMI cable?
What case is your PI 4B in? Maybe the HDMI plug isn’t going in all the way.
Make sure your using HDMI 0 and not HDMI 1

I haven’t tried a different cable because I don’t have another HDMI-to-mini-HDMI cable. I only bought one with my Raspberry Pi. My Pi is in a case I bought off Amazon. And I am using HDMI-0 if that’s the one on the left of the two. Out of interest, why does it matter?

I seen it posted numerous times on the Pi Foundation forum, that if your only using one monitor, use HDMI 0. It’s set as the default port on boot up or something?
If its not a lot of work, I’d take the Pi out of the case just to rule out a connection issue.
I’ve had issues with my Pi Zero’s in some cases. The HDMI didn’t plug in all the way and I wouldn’t get anything on my monitor.

My Pi 4 seems pretty reluctant to come out of the case and I don’t want to break anything.

Ok, if its a hassle leave it as your last option.
You could try setting hdmi_safe=1 in config.txt
Or hdmi_force_hotplug=1
As per,
https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

I haven’t set hdmi_safe=1 but I have set hdmi_force_hotplug=1 and config_hdmi_boost=4 and nothing changed.