No Sound - advmame 3.5 - Picade HAT


Hi all…

I have a Pi, running retropie with a Picade HAT.

All great. I get sound on all emulators, but just tried advmame 3.5 and get no sound. If I run the same ROM on 1.4 advmame, no problem

Is there something new in advmame 3.5 that doesnt like the way the Picade HAT makes sound work with its amp?

Anyone have the same issue?


I haven’t come across this problem before, but it could be a problem with advmame 3.5 handling of audio output device.

It might be worth reverting to regular audio temporarily, and seeing if advmame 3.5 works over the Pi’s built-in 3.5mm jack (assuming you’re not using a Pi Zero).

You can do this by commenting out the line: “dtoverlay=hifiberry-dac” in /boot/config.txt

And making sure the line dtparam=audio=on is present and uncommented.


Perfect and thank you for the suggestion. I’ll give this a go tonight and
see how I get on. Strange it’s only in 3.5 advmame…


I had a go at this and it kept crashing the pi when I opened advmame 3.5 games.

Should dtparam=audio=on always be uncommented in the config.txt?



I gave this a little test this morning.

Ensured tparam=audio=on was there and uncommented
Commented out hifiberry

System, booted. Mame1.4 played sound out of the speaker still, not out of headphone
Advmame 3.5 no sound at all.
I can still see sound bouncing in the EQ in the TAB GUI of Sound - Details.

Very strange :)


I’ve not got any further with this sadly. Advmame 3.5 wont play any sound to the picade.

Very odd. 1.4 adv mame it is for me for now then!


This must be some hack/tweak/hardcoded madness in Advmame that’s missing in 3.5 I had a look through the source/issues on GitHub and can’t find any mention of it, though.

Is there any way you can launch Advmame from the command-line and see what output it gives you? There may be useful messages/errors relating to audio.