Picade together with hifiberry sound module - no sound



I have built my picade and due to that i could never get any sound of the built in 3.5 mm sound output of Pie
i bought myself an hifiberry dac-plus sound module. The module is installed and i get sound from it when connecting my headphones to the 3.5 mm output on the hifiberry. But i can never get this sound playing via
picade controller / speaker. If i connect an external sound to the picade controller, i hear sound for one second when im rebooting the Pie and then it turns off.
I have installed the picade driver, i have followed hifiberry installation info and sound is getting out of the hifiberry but picade controller wont play anything.

my config file looks like this:

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)


Any help is appreciated, thanks!



Bumping the question, anyone knows how to solve sound issue?


The Picade Hat installer switches the sound source from the Pi’s onboard to the DAC on the Picade card. It has to do this to get the sound to come out of the Picade speaker. This basically disables the Pi’s analog audio jack and HDMI sound output. It’s one or the other not both.
And its the same deal with the hifiberry DAC. Its installer switches it to the audio source. Once you do that the speaker and DAC on the Picade Hat are disabled. And there is no way for the signal to go back through the GPIO from the hifiberry to the Picade Hat. Its a digital signal going from the Raspberry Pi to “A” DAC.
I think your lucky one actually works as they are both likely using the Pi’s i2s bus.
Does the hifiberry have a speaker output? If yes connect the Picade speaker to it instead of the Picade.


Hi and thanks for the reply

The hifiberry has its own 3.5 speaker output and i connect the stereocable to that output. If i connect a headphone to that jack i got sound. If i connect cable to the picade board it wont give any sound (but joystick and all buttons are fine)


The hifiberry install likely disabled the X-hat (DAC) and set itself up as the only audio source.
I’m no expert but my understanding is you can only have one DAC being fed at any one time via the i2s bus (GPIO). Its one or the other but not both.