Sound issues buzzing and distorted sound

Edit - - sound working now just getting distortion through speakers any ideas?

Just built the picade 8 usbc with a pi4b all super smooth until I tried to get the speaker in the unit to work, retropie says onboard audio disabled or not present and it won’t let me go any further.

Sound settings via the overlay are
System volume: 52
audio card: default
Audio device: pcm
Omx player audio device: ALSA

I’m a new pi user and just Learning but finding it super frustrating as nothing I try seems to work.

Just so you know I don’t own a Picade or run retropi. That being said, the Pi’s onboard audio will be disabled. By onboard I mean the audio on the Pi that sends sound out of the audio jack or to HDMI. You will likely find an entry in the config.txt that is redirecting it to the Picade Hat via i2s. There is a DAC on the Picade Hat that does the sound though its speaker. How you configure it in RetroPi I have no idea? I would think the Picade Hat installer should do it for you. Maybe the recent switch to Pulse Audio in PiOS is messing things up?

ah that would explain why i cant change any of the audio options

i ran a sound test via the cmd menu and i got quite a bit of crackling and distortion i think i may have a duff speaker :(

can I disable audio on the pihat and use the aux out on the pi to put in a different audio option.

I would think that’s doable. Have a look in your config.txt file for a line with “dac” in it.
It will be something like
change it to
and it will be ignored.
Also look for
if you find it change it to
dtparam=audio=on or #dtparam=audio=off

Anything with a # in front is treated as a comment and ignored, remove the # and its acted upon. You will have to reboot after making the changes for it to read them and act on them.

tried a few things and got my sound working via the onboard speaker my issue now is it works for a bit and then becomes distorted and buzzy i know the speaker works as i tried another speaker and get the exact same issue anyone have any ideas why it would be doing this and how to rectify it


I don’t have any ideas, other than changing the thread title, if possible.
Something like “Picade sound Troubles” might get the right people to see it.

I’m not sure either, I do have a (home made not Pimoroni kit) retro arcade console with a Picade HAT and mostly Pimoroni parts, and I have a speaker wired up to the Picade HAT. I do remember when I first set up the console I had a few issues with the audio, mostly due to retropie not having an easy option to change certain audio settings when the Picade hat install script has run.
I think it was to do with there being a few different menu options. I’m still not entirely sure why it is distorting after being run for a while, my only wild guess would be that some sort of interference is happening or that the connections aren’t very secure, @Lebdude

I have a Pirate Radio setup using the pHat Beat, which I believe uses the same DAC. I’ve run it for hours with no issues. No sound quality issues anyway. It’s not running the latest PiOS though so no Pulse Audio.
You can obtain older versions of PiOS / Buster or Jessie etc here.
Index of /raspbian/images (

If you have a spare SD card you could try last years Buster. Just throwing it out there as a test option. I’ve done it in the past when a new version update broke what was working just fine previously.

Maybe its a heat issue? The Pi 4B throttling the CPU or heat from it doing something to the Picade Hat? Just a bit of a guess really. The Pi 4B can’t overheat, but can get very hot, close to 80c if used hard. As the SOC temperature gets close to 80c the CPU frequency will be reduced to keep the temperature below 80c. This hurts performance.

It dose it from cold so not sure temps seemed normal. I’ve disabled the xhat audio and just gone back to the pi for audio and I’ve got good audio now so thinking it’s an issue with the xhat connectors, I’ve fiddled and fiddled with it even tried a different speaker and got the same results over and over again.

@alphanumeric I also have a pirate radio, run for hours with no issues like you.
@Lebdude as you’ve said that it does it from cold, there’s obviously no issue with heat throttling in this case. I really don’t know what else to suggest, other than to check your connections.

Are the ends of your speaker leads tinned (coated) with solder? Grasping at straws if I’m honest. Kind of sounds (no pun intended) like an issue with the Picade Hat.

@alphanumeric mine have been connected fine ever since I first wired it all up, I’m not sure what’s gone wrong for @Lebdude . I guess potentially there could be an issue with the audio circuitry on the Picade X hat.
Also, as @Lebdude originally mentioned

their speaker could be partially dysfunctional - it might be that sound works some of the time and other times sounds crackly.

It would be good to see a close up of how the wires are supposed to fit into the ports to make sure I’ve fitted them right, the official build vid could really do with some closeups adding in to remove the ambiguity.

You can push the wires in quite a way, so I’m never sure if the contacts are sitting correctly tried it loads of different ways and got the same results. Swapped speaker out and got same results.

The pHat Beat uses those same connectors. The way its supposed to work is you press the striped and tined end of the speaker wire in and stop when you can’t see any bare wire showing. To remove them you press down on the release tabs with a screwdriver so the wires slide out.
I went one step further and used a screwdriver to gently press the release tabs so the wire just slid in without having to be forced. Disclaimer, press too hard and you may break the tab and the wire won’t stay in.
If your wires aren’t tinned with solder, and just the bare strands, make sure no lose strands are shorting the two wires together. I would think you’d get no sound if that happened though.

1 Like

@Lebdude - as you said that you’ve swapped the speaker out and tried another one, the issue can’t be with the speaker. I agree @alphanumeric about how the connectors should go in, you do have to be careful not to break the tabs! I could send a photo of my Picade X Hat with the wires in if that would help? Otherwise it seems like its an issue with the audio circuitry.

I re-enabled the xhat sound options and had another fiddle to see if i could get it working properly again last night and no luck again no matter how i sit the wires i get distorted audio. Think i will just stick with taking the audio from the pi’s 3.5mm jack.

Thanks for all the reply’s really impressed with how helpful and welcoming the community is here.

1 Like

Bummer but at least you have sound. I enjoy coming here. Even when I don’t have a clue I usually learn something by tagging alone in a thread or two. I’m retired so I often have all kinds of free time on my hands.

@alphanumeric I agree too, it’s great to try and help people, I only started recently but it’s really fun to do in free time.