No sound from Pirate radio


#1

Hello
I bought pirate radio, I assembled it an I installed vlc radio based on instruction here.
System “Raspbian GNU/Linux 9 (stretch)”
Seems all works fine, on port 8080 I see that radio is playing, I see process vlc in terminal, led are blinking, but the speaker is mute.
I tried almost all possibilities, but no idea what to do.
I set volume on vlc, I checked also alsa, cables.
Does have someone idea what to check next?
Configuration files seems ok.
I tried speaker test, no sound.
Any logs etc?
How to check hw?
Thank you for your answer!

root@raspberrypi:~# lsmod
Module Size Used by
cmac 3134 1
bnep 11949 2
hci_uart 21222 1
btbcm 7917 1 hci_uart
bluetooth 376017 24 hci_uart,bnep,btbcm
brcmfmac 269987 0
brcmutil 9911 1 brcmfmac
snd_soc_hifiberry_dac 3123 1
cfg80211 527260 1 brcmfmac
rfkill 21373 6 bluetooth,cfg80211
snd_soc_bcm2835_i2s 7257 2
regmap_mmio 3977 1 snd_soc_bcm2835_i2s
snd_soc_pcm5102a 2245 1
bcm2835_gpiomem 3791 2
snd_soc_core 176256 3 snd_soc_bcm2835_i2s,snd_soc_hifiberry_dac,snd_soc_pcm5102a
snd_compress 10144 1 snd_soc_core
snd_pcm_dmaengine 6002 1 snd_soc_core
snd_pcm 97889 5 snd_pcm_dmaengine,snd_soc_bcm2835_i2s,snd_soc_core,snd_soc_hifiberry_dac
snd_timer 22706 1 snd_pcm
snd 68784 5 snd_compress,snd_timer,snd_soc_core,snd_pcm
uio_pdrv_genirq 3718 0
fixed 3029 0
uio 10166 1 uio_pdrv_genirq
ip_tables 12512 0
x_tables 20921 1 ip_tables
ipv6 385200 20
root@raspberrypi:~#

root@raspberrypi:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
root@raspberrypi:~#
root@raspberrypi:~# grep -v ^# /boot/config.txt | grep -v ^$
dtoverlay=i2s-mmap
dtoverlay=hifiberry-dac
root@raspberrypi:~#
root@raspberrypi:~# ps aux | grep vlc
pi 591 12.4 6.0 199024 26940 ? Ssl 19:02 8:52 /usr/bin/vlc --verbose 1 --file-logging --logfile /var/run/vlcd/vlcd.log --alsa-gain 0.065 --audio-filter compressor,volnorm --norm-buff-size 10 --norm-max-level 80.0 --norm-max-level -3 --compressor-attack 50.0 --compressor-release 200.0 --compressor-ratio 20.0 --compressor-threshold 0.0 --compressor-rms-peak 0.0 --compressor-knee 1.0 --compressor-makeup-gain 0.0 --intf dummy --extraintf rc:http --rc-host 0.0.0.0:9294 --rc-fake-tty --http-host 0.0.0.0 --http-port 8080 --http-password raspberry --no-quiet --daemon --pidfile /var/run/vlcd/vlcd.pid /home/pi/.config/vlc/playlist.m3u
root 1136 0.0 0.4 4364 1972 pts/0 S+ 20:14 0:00 grep vlc
root@raspberrypi:~#


#2

Looks like your software setup is okay, could you snap a picture of your hardware setup and of the soldering for the Pi Zero and pHAT BEAT headers?


#3

exactly, I am afraid of the same. :-D.
I am not very practice in soldering.

Is it possible to test it if I did not burn it during soldering?


#4

For someone not very practised you appear to have done a fantastic job. Nothing strikes me as particularly wrong with your soldering! Yes it’s not perfect, but it should work.


#5

When you connected the speaker(s) did you strip some insulation from the ends of the wires so there is a little bit of bare wire? I also like to tin the ends with a little bit of solder. If only one speaker, switch on the back in mono? Instead of forcefully pushing the bare wires in I like to press the release tabs lightly with a small screw driver until the wires slide in easily. Like you would to remove them. Do you have one speaker or two hooked up?


#6

Your soldering actually looks pretty good. Here is the pinout for the pHat Beat


Double check those pins, if you see one that looks kind of frosted, just reflow the solder so it fully melted, then let it harden with no movement. Something that’s hard to spot from a picture is a cold solder joint. I’m not saying that’s what you did, juts that it doesn’t hurt to double check things to rule it out. That’s one of the nicer soldering jobs I’ve seen posted here.


#7

It was soldered a little from factory, but I striped them a little bit more. I tried to change from left side to right side, I tried to switch from stereo to mono.
I pressed it also with small screw driver.
I have one speaker, it is set from “Pirate Radio” package.


#8

Ok, thank you for now,I’ll check it out later this afternoon


#9

Ok, you bought the full kit, I wasn’t 100% sure that was what you did. I only bought the pHat Beat and made my own case. I run two speakers. According to the guide, “Connect the black speaker wire to the left - terminal and the red wire to the left + terminal (although you can equally well use the right channel as blended mono is output through both channels when pHAT BEAT is in mono mode)” your doing it all correctly and should have sound?.
https://learn.pimoroni.com/tutorial/sandyj/assembling-pirate-radio

Do you have another speaker you could hook up to test with?


#10

Please take a close look at the amplifiers on your phatbeat. On one of mine one amplifier was mislocated during assembly. I will try to get a closeup picture added


#11

this is my closeup.


#12

It seems that it is not my case.
Amplifier was assembled fine.


#13

I tried all of it and nothing. Still mute.
Unfortunately I don’t have other speaker I’ll look into some old devices :-D
I want to do one more radio, so I ordered second pHat, we will see if the issue is on hw.
I will send update in 2 days.


#14

I’m currently setting up a Pi to test audio and am having some trouble! Too soon to call it now, but did you use the very latest release of Raspbian?

Edit: False alarm, I’d borked something up and I have no idea what. A fresh image has audio working for me.

P.S. have you tried the beta Pirate Radio firmware? It should eliminate any chance of software from the equation. You can find it here: PiratePython - Pirate Radio


#15

Hello and thank you to all!
Yesterday I received new pHat, I soldered it and it works ok now and playing.
Yes, I am using the latest raspbian, strech.
I have still a troubles, but it is not based on hw, so I hope that I’ll manage it.