Octocam not working with motioneye

Setup octocam with motioneye but after opening the motioneye url the cam section keep scrolling and no preview is showing up. Please help me to resolve it.

Double check the camera connection at the Pi’s CSI connector. Be careful unlocking locking it, the locking bar breaks easily. If the ribbon cable isn’t in all the way or flipped over the wrong way its the same as no camera being connected.

I’m using a similar camera in Motion Eye with no issues.

And a couple of the official V2 cameras.

What does it show under Video Devices?
Mine shows
Camera Device vc.ril.camera
Camera Type MMAL Camera

Also try reducing the resolution to 180x720 or something, at least until you get it working. If its not already set lower by default.

What browser are you using to view the motion eye web page?

If it is chrome then there is a new known bug in it the fouls up the motion eye camera image part only showing the rotating iris.

Google “chrome and motioneye” and you will see a flag setting to change.

Edit: the Chrome fix is to put this in the address bar and change “default” to “disabled”


I did couple of things till I get it working.

a) Setup Raspbian and perform image test using below command.
raspistill -o testshot.jpg

I found that its working which proves that no problem with camera or connection.

b) Earlier using powerbank to power pi zero w. Changed to Anker wall charger to provide enough juice to pi and viola it worked. After rebooting, it started showing up video review on Firefox browser. Using old chrome browser also seems working as I did not test it with recent chrome as per neilman suggestion.

c) Fiddle with camera resolution and setup to 1080 seems no issue.

d) Also, changed from wifi to Ethernet and it gave better result with streaming.

However, following never worked as I tried out couple of times and it failed to register the changes.

  • setting up to goggle drive to capture video.
  • Motion detection is either hit or miss.
  • Old powerbank to power pi - Which powerbank will be best suited for job, still I am not sure. Any suggestion would be highly appreciated.

Thank you all for suggestion.It really helped :)

I had originally tried streaming video to a web browser with a Zero W. It lagged and stuttered badly. I’ve since switched to Pi 3A+'s with much better results. I have my resolution set to 720P, 1280x720. The camera can do up to 60 FPS @ 720P but only 30 @ 11080P. I’m getting about 30 FPS over WIFI. I’m using the official power supply.
I gave up trying to get the motion to work. I’ll be honest and say I didn’t spend a whole lot of time trying to get it to work. For me it either didn’t work, or took way too many stills.