pHAT DAC not working


#1

I got a pHAT DAC for my birthday and just tried to set it up with my RPi2, running Raspbian upgraded to stretch, but it’s not outputting any sound. Everything appeared normal (ie output of aplay -l and aplay -L etc), except that speaker-test over ssh caused the connection to freeze. It seemed to work normally when logged in at a console, apart from being silent, so I don’t know if the ssh freeze is signifcant or just an irrelevant weird quirk.

mplayer tries to play my files, without showing any errors, but again the speakers are silent.

Then I tried plugging and unplugging the jack plug and discovered that when it’s halfway in it makes a kind of random noise (mostly white noise but with some sort of modulation) and this also seems to trigger kernel panics. So presumably I have faulty hardware? My soldering on the I2C connector isn’t the prettiest, but I’ve examined it closely several times, and can’t see any sign of a dry joint or short anywhere.

I reversed the changes the setup script made (to /boot/config.txt and /etc/asound.conf) and went back to the internal audio, which works fine with the same jack-to-phonos cable and amplifier, as it did before, so that rules out a problem between DAC and amp.


#2

it’s entirely possible you have a hardware fault… that said, I can’t recommend you run Raspbian Stretch at this stage - your issue may or may not be related.

… so, ensure first of all that you get the same issue on Jessie. Best test is via speaker-test right from the station (although I often run it over ssh and I’m not aware of any potential complications doing so).


#3

Problem solved.

At first Jessie wouldn’t boot at all with the HAT physically installed, but it did after I unplugged it and plugged it back in, and it output sound too. So I restored my Stretch image and now that can play sound successfully through the DAC too. There was probably too much dust on the Pi’s I2C connector I guess.

Thanks for your help, but I would have been very disappointed if it was an incompatibility with newer kernels etc. Everything significant should be working in Stretch now, with it so close to release, and I’ve always found Debian “testing” very reliable in general (better than Ubuntu LTS even) with a lot to offer over a stable distro that’s a couple of years old, and being able to start from a reasonably up-to-date mopidy and gstreamer makes things much easier for me.


#4

if your Pi did not boot, it is possible you fitted it offset shorting 5v to ground. Be extra careful when popping a HAT/pHAT on, it can easily be done, potentially damaging the Pi and/or HAT.

but, sure, I use debian stretch myself, daily - the main point is that it is a moving goal post, and it’s impossible for us to test in this environment, or attempt to reproduce issues users such as yourself may experienced. so ruling out any hardware fault against a known environment makes sense ;-)

… either way, all good, and glad to hear it works now.


#5

Unfortunately I spoke too soon. I thought the speaker-test sounded a bit dull, but assumed it was a poor quality wav… But when I played music through it I realised it’s the hardware. There’s no treble, it sounds dreadful. I should have just been content with repurposing my UFO202, but seeing as I’ve now gone and ordered a phono socket for the pHAT I suppose I should try a replacement. It was bought for me as a present from Amazon. Should I try to arrange a return through them or send it direct to you? I might have to do the latter anyway if it was bought too long before Christmas.


#6

yes, please contact our support, they will provide you with a replacement.