pHAT DAC "no soundcards found"


#1

Hi all,

I recently got the pHAT DAC Wireless Audio Kit.

I gave it a fresh install of Rasbpian Jessie, from https://www.raspberrypi.org/downloads/raspbian/
Specifically:

Version:        May 2016
Release date:   2016-05-10
Kernel version: 4.4

I’ve been following the instructions on http://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install but so far I’ve not had any luck getting the Pi to recognise the DAC.

e.g.

lucy@estelwen:~ $ aplay -l
aplay: device_list:268: no soundcards found...

I used the script to set this up, curl -sS get.pimoroni.com/phatdac | bash

Following the manual steps, the files the script would have touched all look as follows:

lucy@estelwen:~ $ cat /etc/modprobe.d/raspi-blacklist.conf



lucy@estelwen:~ $ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

i2c-dev



lucy@estelwen:~ $ cat /etc/asound.conf
pcm.!default {
 type hw
 card 0
}
ctl.!default {
 type hw
 card 0
}



lucy@estelwen:~ $ cat /boot/config.txt | tail -n 10

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on
dtoverlay=i2s-mmap
dtoverlay=hifiberry-dac

Any ideas what I’m missing?


#2

The 4.4 kernel relies on the device tree more extensively, but that should not really affect the current installer.

I guess the more likely issue is that the soldering on the pHAT DAC is flawed in some way. Did you solder the included header or used a custom solution?

Did you solder all points? You can see the important ones in the pic linked in the following thread:

http://forums.pimoroni.com/t/phat-header-soldering-the-lazy-way/1690

… I might be worth giving those a touch up and see if things work then.


#3

Thanks, I’ll give it another look tonight.

I know I didn’t put anywhere near as much solder on the pins as in those photos, so possibly some or all of the connections aren’t good enough.

I hadn’t considered that it might be a hardware issue actually.


#4

No luck. Here’s a photo of the DAC and the Pi.

Not sure if there’s enough solder on there or not.



#5

Well now I feel dumb. :P

Got it working. Solder’s all fine (spent a while with http://wiringpi.com/ to verify that.

Turns out that I needed to run the script from http://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install as root.
D’oh!


#6

hum, that’s strange, it shouldn’t be necessary… is your ‘lucy’ user not part of the sudo group then? Either way, the configs you posted seemed fine.


#7

Yeah, likely I’ve got the user set up wrong.

Something I’ll figure out later if I have the time. For now it does what I needed it to :)