Phat Dac Picade Help


#1

Hi all,

I’m little bit stuck.

I have just install a Phat Dac and my sound only works for about 10 seconds. The sound turns down low so I can’t hear anything, I can turn up the volume but it will just go low again.

Currently using Retropie Image Version 3.2.1, and have the lineout of the Dac connected to the Picade board.

I have followed this guide http://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install

Any help would be much appreciated.

Chris


#2

This sounds like the power problems all over again. A single 2A power supply just isn’t enough to power the Picade PCB, Screen and Pi, specially when the Picade is turned up and drawing a lot of power. I’m guessing the Picade PCB is simply resetting and turning down the volume.

If you look through the various posts here you’ll find a number of power solutions which should help.


#3

Hi,

Yes it’s defiantly a power issue.

If I have the Screen / Raspberry Pi2 + Dac / Picade Board on separate powers supply’s the sound is fine, but with this combo the arcade buttons won’t work.

Is there a way to power the Picade Board separately and have it connected to the Raspberry Pi?


#4

Hiya,
I’m also having a few issues with the pHAT DAC when used with Picade, and I’m hoping you can help…

I have the usb out from Picade board plugged into Pi2Bv1.1, the screen on a separate power supply, and the Pimoroni supplied 2A USB power supply for the Pi2 itself. I have the stereo jack on the Picade directly connected to the stereo jack on the pHAT DAC, and the standard issue speakers.

When I try running with retropie 3.3.1, and I used the config script at http://pinout.xyz/pinout/phat_dac , I get the following issue, which I didn’t get before installing the pHAT DAC, it runs for a bit, but when I gently press an arcade button, it will pull the sound right down, I can bring it up again with the volume buttons, but it will come down again.
I have tried setting max_usb_current=1 to no avail.

As a secondary issue MAME doesn’t appear to work anymore (it did without the pHAT DAC) as it now says “lv10: VolumeControl::init() - Failed to find mixer elements!” when starting a ROM, and then returns to the EmulationStation screen.

If it is a power thing, can the Picade be powered separately, and yet still have a USB connection to the Pi2, and if so how?

Thanks for your help,

Jez

P.S. I’ve really been enjoying the Picade, it is a quality bit of kit, and has been working brilliantly. I have even got BeebEm working on it, and remapped the keys (in game) for Chuckie Egg to the Picade controls, yay.


#5

or could this be a sign that I have an issue with my soldering of the pHAT DAC?

Also, I have reverted the 4 config files changed for the pHAT DAC install, and connected to the Pi2 hissy audio jack, and both the issues above work again but with the usual background hiss.

I’d really love to have the clarity of pHAT DAC working with the Picade, so any help is gratefully received,

Cheers

Jez


#6

As a workaround, adding “disable_audio_dither=1” to the /boot/config.txt file has made a significant difference to the background hiss when using the Pi2 stereo jack (as mentioned by @Spacemonkey earlier in this forum)

I’d still be interested if @gadgetoid or anyone else has some ideas about getting the pHAT DAC to work correctly, as I asked above (i.e. bumping this thread :-) )

Cheers

Jez


#7

Hi

I’m having the same issue with Mame but I don’t think this is something Pimoroni can fix. I have posted on the RetroPie forum to see if they have a solution.

I don’t however have your other issue with the sound being reduced when using the arcade buttons only when using the volume controls.

Cheers

Paul


#8

you could split a usb cable so the data lines are coming from the pi to picade, but the power feed comes from a separate power supply. would just involve some soldering, and joining of the respective cables

if you used a decent multicharger, like an Anker USB Charger, the problem would be solved as these output up to 2.8a to each output.
you could even run the 8" screen off of one of the outer outputs
mike


#9

Hi,

I’ve been experiencing the same issue too, so I was wondering if anyone had found a solution yet?

I’ve been using Lakka instead of RetroPie, and I have a 60w usb power supply but other than that my setup is identical to a 8" Picade. I had no problems at all with the default analogue RPI audio output, other than the normal hissing and poor quality state of it, no matter how loud I turned up the Picade PCB volume.

I bought and connected a Phat-DAC to improve the sound quality - which it has - but now I’m getting the same automatic volume decrease that is reported here. I turn it back up and the Picade PCB turns it self back down after a few seconds. Oddly, it happens a lot more frequently, on certain emulator cores, mostly the SNES, and NES and MAME ones, but not on PSX or PC-engine. So far I’ve tried a few things…

First, I plugged in a USB power splitter cable to power the Picade PCB from the 60W USB power supply (a six port Anker one). That didn’t improve the issue at all.

Next, I tried turning down the volume on the Picade PCB, to try and limit the current draw the amp was pulling, this also made no difference either.

What did make a difference was dropping the output volume from inside the emulator itself (using Lakka’s internal audio config). With the output volume from the Phat DAC reduced, I can turn the Picade volume right up and not get a problem… most of the time, unless there’s a really big loud bang from an explosion, and turning the internal volume down further continues to mitigate the issue. I’ve tried this both with and without the USB splitter cable powering the Picade PCB, and it seems to make no difference at all.

So I can’t be 100% sure in any way but I’m wondering if the Picade PCB has some kind of input protection/volume throttling built into it, and it’s simply a case of the Phat DAC being too loud/distorted/clipping? Is this likely, and does anyone have the time to check/try this out to see if it works for them too?

Cheers in advance for your help! :)


#10

Hi

I have exactly the same issue. I thought it was a mechanical issue on volume down button originally but have since realised it is only caused by certain sounds.
I am also using anker 60w 6port power hub. One port to screen and other to pi.
Pi has phatdac providing sound and a usb keyboard dongle and is connect to picade pcb.
I have tried 3 different pcb firmware files, original 2.2 and 2.3.
I tried lowering sound to 10% in alsamixer and raise volume via picade pcb amp this had no effect.
I will try without phatdac and also using 3rd power port to provide power to picade pcb.

If anyone knows a fix to this issue please let me know.
Thanks


#11

Just diving in here to say sorry, this thread has slipped through the net a little.

I don’t know the precise electrical cause of this problem, but if I remember correctly from experiencing it with a desktop computer, the gist of it is that the headphone detect is being triggered somehow.

This causes the Picade PCB to think headphones are plugged in, and so it slowly fades down the volume automatically.

I’ll ask our engineer extraordinaire to see if there’s a hard fix for this problem, but for the time being would anyone be willing to try out a modified firmware with the headphone detect functionality simply disabled? This doesn’t stop you from manually turning down the volume when headphones are plugged in, but should hopefully fix this problem.


#12

Hi

I have tried original 2.2 and 2.3 firmwares as mentioned before.
Issue persists.
I have also reimaged to see if any changes I did caused this but issue is also there.
I have tried without phatdac and issue goes away.
Looks like its the combination of phatdac and picade controller that causes this.

Thanks

Brad


#13

strange… I wonder if you have one of the ‘overly-bassy’ pHAT DAC and that’s one factor. Have you tried the DAC direct to an amp and how does it sound?


#14

A modified firmware should still help things- by removing the headphone detect/volume ducking altogether. I believe it’s a combination of an electrical issue triggering headphone detect, and then the automatic volume ducking (entirely in software) kicking in.


#15

Hiya,

Thanks very much for looking into it for us, hopefully we can figure what’s causing it between us.

I’m happy to try a new firmware if you want, you just might have to talk me through how to punt it onto the picade pcb if the procedure is different to the normal one.

:)


#16

for Picade PCB upgrade there is now a one-line installer you can use. I think once we have the next experimental firmware ready we’ll try to make it an option to flash it instead of the current stable one.

… but before I forget here it is (functional right now, albeit only flashing the latest ‘regular’ firmware):

curl https://get.pimoroni.com/picadefw | bash

#17

Not sure, Ill give it a bash and let you know.


#18

I see there is a newer version from 2 hrs ago picade_v2.3_no-headphone-detect.hex , Ill give it a try tonight.
Thanks


#19

yes, please follow the instructions @gadgetoid posted in the other thread, the ‘multi-option’ feature has not yet been integrated into the above.


#20

Thanks very much, that seems to have fixed the volume issues, there’s no longer any volume drop out for me.

Randomly, I’ve now got key press issues but that might be me upgrading the version of the software (I’m using Lakka at the mo, so need to re-install retropie and check with that to be sure). I’'ll re-check those and get back once I’m more sure it’s not just something daft I’ve done.

Thanks very much for your help! :)