Phat Dac problem - Board not recognized


#1

Hi! I recently bought the phat dac. My plan was to build a music server with the rpi zero. The problem is that the board hasn’t been recognized. I run as root curl -sS get.pimoroni.com/phatdac | bash
Here is the output of the sound test:

pi@raspberrypi:~ $ speaker-test -c2 /t wav

speaker-test 1.0.28

Playback device is default Stream parameters are 48000Hz, S16_LE, 2 channels Using 16 octaves of pink noise Playback open error: -2,No such file or directory

And also the output of the lsmod:

pi@raspberrypi:~ $ lsmod Module Size Used by ctr 4005 2 ccm 8334 2 arc4 1956 2 mt7601u 85170 0 mac80211 595686 1 mt7601u cfg80211 479279 2 mac80211,mt7601u rfkill 21508 2 cfg80211 bcm2835_rng 2207 0 bcm2835_gpiomem 3703 0 uio_pdrv_genirq 3526 0 uio 10078 1 uio_pdrv_genirq i2c_dev 6386 0 fuse 86348 3 ipv6 358811 32

I can provide some pictures of the work on both boards. I’ve checked with a multimeter if all of the pins have conductivity to the rpi, and if one of them touch another pin.

Can someone help me with this? I don have any other idea to test.

Thanks!, Leo


#2

What does running the script again do, does it offer to conduct a test? Have you restarted the Pi since running the script?


#3

It offers to perform a sound test. But first i reboot it. Then i run the script again and perform the sound test.
Now i just run as root the soundtest.


#4

I’m not sure I am following what you are saying.

Incidentally, your syntax for the sound test pasted above is incorrect, it should be:

speaker-test -c2 -t wav

which is quite possibly why you got the output you got then. The script should work without sudo in any case (and runs this exact test). Well, it does elevate privilieges as needed for steps where that is necessary.


#5

Sorry that was a typo, and yes, i run as user and get the same error


#6

I can certainly say that lsmod’s output is not what I’d expect. It has no trace of the dac and contains entries unknown to me.

I can only recommend you try in the first instance to confirm the phat DAC works against a full clean Jessie download without addition, and troubleshhot from there.

… my suspicion is that you are loading multiple overlays, maybe a copy of your /boot/config.txt could shed some light on the matter…


#7

Ok, this was with a clean copy. Later i will put a clean copy of jessie (and if i can i will test with the raspi3) and test it again. But before that, here is the actual config.txt and thanks for the help!!!

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on
dtoverlay=hifiberry-dac


#8

yes, that looks like a clean config to me, with the modification that the phatdac script provides.

… strange, even without hardware fitted (let alone some dry joints, should that be the case) lsmod should show the modules loaded by the overlay. Could it be that it was the output before a reboot?


#9

No, this is the config after reboot. So, later i will install a fresh jessie copy in the raspi 3 and see what happend. I will post the results.

Thanks again and sorry for my english!


#10

I test the dac in te raspi3 with openelec and it worked just fine.
So, tomorrow i will test again with a fresh install of jessie. If there is any problem (soft or hard) it must be in the rp0. I will post the results,

thanks Leo.


#11

So, i did a fresh install of jessie, and made the modifications to support the dac manually. It worked!!

Thanks for your time RogueM!!