Pi Zero W and Mote Not Working


#1

I’ve been using Mote for an ongoing LED project that I’ve successfully been able to use with my Pi Zero. It is NOT working using the Pi Zero W. I have tried to both update/upgrade my functioning Pi Image and have also tried with a fresh install of Raspian on my Pi Zero W. Both are giving me the same error (attempting via SSH, but have the same problem with the GUI):

Traceback (most recent call last):
   File "image-paint_test.py", line 128, in <module>
      mote = Mote()
   File "build/bdist.linux-armv61/egg/mote/__init__.py", line 37, in __init__ IOError:Unable to find Mote device

Any ideas of where I should start to troubleshoot this?


#2

OK, so I troubleshot and it works now!

It’s fun how a crappy USB hub and a non-Pimoroni USB-Micro cable can be what messes this up.


#3

I have had alot of hub issues with the Pi zero’s. Most the cheap Ebay hubs seem to only partially work or not at all. I don’t know if its a cheap chip in the hub or what, its not power because I had created an inbetween to add separate power to hubs and I still get the same issues. Or if I use the 5v 2.5a to power the zero & hub together hub still doesn’t work.
One odd thing I had run into is some devices not found through a hub that seems to work well will be found when my Pi is run through my lapdock 100.