Mote Hub isn't getting recognized on Windows and Pi


#1

Hello Support,
A few days ago I bought a Mote-Set with just one strip.
I installed mote (and requirements) on both, Windows 7 64bit and Pi 3 B+ Raspbian) and mote still says “OSError(‘Unable to find Mote device’)”. I also looked in the device-manager but i was unable to find the mote hub. I put the hub in again (on other port) and for a second I saw “Undefined device” and then it “fizzles” in nothing…

So what should I do now?
MFG Jannify


#2

On your Raspberry Pi what do you see if you run dmesg -w on the Terminal- which should watch system message output- and then plug it in?

Have you tried swapping out the microUSB cable? 9 times out of 10 that’s the bit that goes wrong with anything USB. (I speak from frustrating experiences of my own!)


#3

Yeah, I swapped the cables before you wrote it but still it’s not working. Now I see the “Mote USB Dock” in the device-manager but it’s still not working on Windows. On Linux (Pi) it’s working perfect by the way.
I have attached a image from VS which shows that pyserial (tested with version 3.4 and 3.2.1) can’t get the ports.
Screenshot_4


#4

Windows 7 lacks the ability to recognise standard CDC USB Serial devices and automatically install drivers, so you must install the .inf driver found here: https://github.com/pimoroni/mote/tree/master/python/demo/windows