Picade 2019 edition

hi all I have bought a picade 2019 edition 10 inch model (states for pi4) I have used a pi3b hope this is not an issue

I have built the machine and it powers on and loads emulation station and all the games.
but I have three issues.

  1. the power button did not work looks like it supposed to stay in but does not work, I have removed the wiring and the machine boots as normal, I have odered a new button.

  2. I have no sound coming from the speaker at all and not sure how to get this working.

  3. I cant seem to config the buttons to work with the majority of the games.

I am a total noob when it comes to the pi……………can someone please help before I just put the picade on the shelf and forget it.

Mr Frustrated

Let me just state that I don’t have a Picade, not yet anyway.
That power button could very well be a momentary switch (non latching). I say this because a raspberry Pi can be booted up by simply momentarily grounding GPIO 3. And shut down by momentarily grounding that same pin.
Did you run curl https://get.pimoroni.com/picadehat | bash from a terminal window? That should setup the sound and other bits for use.

the power button was definitely broken.

yes I did run curl https://get.pimoroni.com/picadehat | bash - does the “picade |
bash” need the space inbetween the words as I didn’t leave a space?

I might just give that a bash (pardon the pun)

nope tried with the curl with the space and still no sound :(.

Any other ideas anyone??

Its picadehat, space, then the pipe symbol, space, bash. On my keyboard the pipe symbol is the character above the \ . Shift \ to get " | ". It looks like a lower case L but its not.

yeah tried that still no sound…

Ok, double check the speaker wiring, especially at the picade X hat press fit terminals.
The wire has to be stripped bare at the end, and if you push it in to far it likely won’t make contact.
The Phat Beat has those connectors. What I did was press the terminal with a screwdriver like you do to remove the wire. I press just enough so the bare end of my wire slides in easily.

hi thanks tried that and still no sound tried resitting the hat as well to make sure it was flush and the contacts were correct.

im wondering if I have a faulty speaker or xhat board.

or its not a physical issue at all and a software issue driving the board???

too many possible issues

not as straight forward as it should be really…

thanks for the continued help any other ideas?

I don’t have any other ideas. Wish my Linux skills were better to know what to look at for etc.
Maybe Phil @gadgetoid or Sandy @sandyjmacdonald can help?

1 Like

thanks you still took the time out to try and help and that’s much appreciated… I have emailed the support team see if that gets me anywhere!!

I have no sound either. Wiring looks fine. Video displays on external monitor (screen connectors broke off – still trying to get that fixed).

Hi All,

turns out you cant just throw in an image you already have, did a new install of retropi and after running the initial set up again it worked immediately.

thanks all

hey you were correct about the button the new button is non latching- i think the contacts were broken on the old button as they kept pushing into the button.

Looks like we were both right, it was broken, and its non latching.
Anyway, now that you have it working , have some fun. =)

1 Like