Picade Build Issues - Screen goes out after PIcade Hat install

Hello,

I am new to the Picade. I just built a new 2019 8" version. Using a raspberry pi 4 2gb Installation went fine. I’ve dug through the forms for my problem, but I haven’t found anyone with a similar issue. Here goes:

  • I had a toshiba 4gb card to test the system. card flash went fine.
    installed the card - system booted up with text down the full screen, retropie logo and then controller configurator.

  • I changed the location to the US to get the keyboard to work (wired xbox controller works in the pi too) and i used a network cable for internet.

  • F4 - Got into the command prompt and typed the code to get the hat drive to install.

  • that ran fine and i got the following screen:

i rebooted, and that’s where the oddities begin. After reboot, i get the rainbow colored rectangle splash screen and then a series of text, but now the text only is displayed on the upper half of the screen - nothing below. and then the screen goes black. I also tried plugging it into another screen (TV) and get the same pattern there. PImoni led is on after the flash.

I re-flashed drive again. same process. same results.
I tried a 128gb micro sd I had around, but i get the ‘no signal’ on the screen with that one.

i can play all the retropie that i want with the xbox controller - it’s when i try to get the hat going that something is fishy. Ive tried the joystick connector both ways even though i know i have it the right way based on the picade tutorial.

Any ideas what’s going on? I can send more screen shots if that helps. I have an official raspberry pi 4b and an offical usb-c charger from raspberry pi. it’s plugged into the USB-C on the Picade hat.

I also got the 128 GB card to work and it produces the same results. for some reason, i had to plug the screen into it’s own plug rather than the microusb to the usb raspberry pi. i guess the power draw is too much for the sandisk extreme.

now both cards are producing the same exact results. i tested both cards running raspbian as well. both run it cleanly.

i have the exact same issue. i am using sandisk extreme pro 32gb.
did you find any workarounds?