Picade No power USB-C

Hi, I’m using Raspberry Pi 3 model b, with Retropie, Picade X Hat and arcade button set. I’ve downloaded Picade software & mapped buttons, all seems ok, however I’m not getting any power when I try using USB-C on Picade X HAT, there was no power button in the kit, so used 1 of my own, which I know works, as pressing it when using retropie shuts down pi. My usb-c power works fine & is 5V 3A, pressing my button won’t turn it on & neither does pressing switch on Picade.

I’m making the assumption that the statement Picade X HAT is now Raspberry Pi 4 compatible, with USB-C power! does not mean only the Rpi4 works off the usb-c, they still use/connect to all gpio’s?

Any help/advice appreciated.

The button you need to use is a momentary contact button. Like the arcade buttons, it only makes contact when and while pressed. It sounds like that what your using but I figured I mention it anyway.
Do you have a USB C power supply plugged into the USB C jack on the Picade X Hat? Just double checking.
The PI 3B has the same pinout as the 4B so it should work OK with the Picade X Hat.

Hi, yes momentary switch, which as it worked to turn off, I assume is not issue & yes plugged into usb-c on Picade

Ok, it sounds like there is a fault on the Picade X hat. The following link will let you contact Pimoroni directly via e-mail. I’d put a link to this thread in your tech support e-mail. Then see what they say.

Hi, Thank you, however I’ve got it working, the cable I was using was for my new phone, USB-C to USB-C, then I had a thought, I remembered reading something years ago about a USB having 2 power options, (firewire rings a bell), so I tried my old phone cable, which is USB-C to USB-A, I had to turn the USB-C connector the other way and then it worked, however no matter what orientation either end of the USB-C to USB-C is, it won’t, so i’ll have to get an official USB-C power cable ordered.

I don’t know about the Picade X USB C input, but the Pi 4B (first release) has issues with the E marked USB C cables. They don’t work with it. Something to do with two resistors and the signaling done over USB C to set the voltage at 5V.
The Pi foundation have done a revision to the board to fix it. It’s only an issue on the Pi 4B “if” you use something other than the official power supply, and it has an E marked cable. Something like that.

Ok thanks, will look at ordering official cable