Picade PCB connection old controler failed


#1

I tried to build a arcade with my old Joystick connected to a 15 pin gameport (https://en.wikipedia.org/wiki/Game_port). I connected the 4 buttons and the 4 axis of the joystick with the Picade PCB. The Picade is connected USB to an Raspi 3. Did the Joystick need 5 V (I connect pin 1 to GPIO1 ?).
Problem: Retropie did not detect the Joystick.


#2

I’ve only a basic understanding of what you’re trying to accomplish here, since I don’t possess any game port joysticks, and have never tried to use them, but is it just the joystick that’s failing to detect? IE: The X/Y axis. Do buttons function as you expect them to?

It looks like the X and Y axis of the Joystick are the center pole of a 100k Ohm variable resistor. Picade should support this with the latest firmware.


#3

no XY axis, no buttons
nothing


#4

You can verify that the Picade PCB itself is behaving by using the ends of a male to male jumper jerky to short any one of the button connections to ground.

As for the rest- I don’t know enough about Game Port to be of much use. You should double-check your wiring against a Game Port schematic, and probably liberally employ a multi-meter.

From looking over schematics myself, it appears like at least the buttons should work; but since the Picade PCB was never designed with Game Port in mind, your mileage may vary.