Picade X HAT sound volume too high

Hi guys.

Thanks, but sadly didn’t change anything on my build :(. I am currently wiping back to an old build just to get the machine working properly again.

@hel Your solution worked for me thanks! I didn’t try any of the other “solutions” listed here though. Would there be a way to get volume control working through the hotkey and up/down with the stick?

EDIT: But now I get a kernel panic error on shutdown.

@mrfootlong I was having the same issue as you, where the amixer command was not displaying any results to me on the command line. Did the same uninstall / install steps you tried and still not resolved like you

Did you ever end up resolving the issue in any way?

I’m having the same problem with amixer not displaying anything. With pulseaudio installed it adds ‘Master’ and ‘Capture’ but no ‘PCM’ and therefore volume control doesn’t work. It plays full blast.

This is with an existing Raspbian Buster and a manual install of RetroPie on an 3B+.

The asound.conf from the Picade installer is in the right place and correct and I don’t have any other alsa configs anywhere. I don’t why PCM doesn’t show up as an option.

I think I just resolved it. I read a sentence somewhere that you have play sound for the PCM option to show up – so I ran the “speaker-test” and it was very loud on the picade. But after that PCM device appeared in amixer and I was able to go into Retropie and adjust the volume normally for the first time.

I have yet to see if this survives a reboot.

EDIT: Survived the reboot. So it seems like that solved it for me.

Was there ever an official solution to this issue? I’ve just built myself a Picade 10", followed the installation guide as shown:

  1. Installed a fresh image of RetroPie 4.7.1
  2. Ran the install script
  3. uninstalled pulseaudio
  4. have my es settings on pcm and alsa

The volume is stuck at max no matter what I set the volume level to and I’m really not sure where to go from here.

This also worked for me! Thanks @hel - a follow-on question would be whether it would be possible to provide a mechanical way to set the volume, i.e., introduce a pot in the speaker wire and just turn it up and down that way. Yes, that’s old school but seems like it should work!

Can I bring this issue up to the top again please.

Just built latest issue Picade with latest s/w builds and this is STILL an issue. Volume stuck at max - control settings make no difference!

Please, Pimoroni, can you come up with a decent solution.

Picade is unusable like this!

I’ve just blown the dust of my 10" Picade and started again from scratch with the latest build of Retropie 4.8, running on a Pi 4 with the USB-C Picade X HAT.
I’ve hit exactly the same problem as originally described in this thread - volume stuck at 100%, and can’t get any of the suggested fixes to work unfortunately. Has anyone recently fixed this issue with the latest Retropie 4.8 image?
I can set ES to all the settings in the screenshot from @hel but the volume doesn’t stick. When I go back to Sound Settings, it shows as 0% again, but the clicks navigating the UI are 100% and far too loud.
Dropping to the console with F4, you can see each of the attempts to alter volume has resulted in the same as sallonoroff :
Apr 14 13:05:11 lvl0: VolumeControl::init() - Failed to find mixer elements!

Pulseaudio isn’t installed when I try to remove it.

amixer returns nothing despite uninstalling and reinstalling it…

So a few more hours of head scratching, and it sounds like a common problem…

Apparently the Picade X Hat doesn’t have a hardware mixer so volume is supposed to work via a software mixer: Picade volume stuck at high - RetroPie Forum

Creating a new softvol device via .asoundrc Alsa Opensrc Org - Independent ALSA and linux audio support site meant alsamixer now had a volume control for the card (snd_rpi_hifiberry_dac). Setting this volume then also meant amixer outputs with the new volume details.

The last piece of the fix was then setting the Audio Device in Emulation Station to use the newly created one from .asoundrc (Master in my case). Volume now working with RetroPie 4.8!

1 Like

Hooray! Any chance you could drop that info in this Github issue @SignUp? Unable to control volume · Issue #38 · pimoroni/picade-hat · GitHub

I’ve recorded the details there, although others have also linked the two items together.
I’d suggest a broader fix for the benefit of the community would be to update the picadehat script to include that setting up of a new softvol device, if anyone is around to maintain and update the script?
I would guess most new purchasers of the Picade are going to attempt the latest Retropie image which since 4.8 needs this fix.

When I started again from scratch at the weekend and tried to document the process, I had a different experience. This time I didn’t need to edit .asoundrc at all, full post here: