Pico Wireless pack SPI select error

My two day old Pico Wireless pack is no longer working.
I’m using CircuitPython and I changed the pin numbers in my program as shown on your web page and it was working fine but now i just get an ESP32 timed out on SPI select error.
Is there any way to rescue it?
I have tried another Pico Board

hello, i’m no expert ,but I would think you can just set the wireless pack up again as you likely had to do before using it ,follow the steps here,its what i would do if it were mine ,but as I said I’m no expert, and i got fried Pico’s to prove it, lol, you can wait to see what other helpers suggest !
Pico Wireless Pack – Pimoroni

That’s how I set it up in the first place, like I said it was working but now it’s stopped.

Have to start somewhere so I’ll ask the obvious first.

Have you power cycled it / reset it?
I don’t have one, just so you know.

EDIT: Did you solder the header onto the PICO?
If yes, how are your soldering skills?

Yes I’ve power cycled it and reset it. I’ve even tried another pico with it. My soldering skills are very good.

Have you tried running any other files / examples on it?

I’ve got one. I use it with micropython and the example program works properly. I suggest you nuke the UF2, put in the Pimoroni UF2 and try the example and set the built in LED with your phone.

I do find it takes some time to join the network - this is quite variable.

My problem is I have done so little HTML that creating buttons, rather than the form is a bit beyond me at the moment.

1 Like

I’ve tried that and it still doesn’t work.