Powering the new Picade


#1

Hi,
I’ve been having bother powering the Picade successfully from the official 2.5A pi charger, when I hit the power button the screen powers on, displays no signal and retropie never appears on the screen. (I’ve also tried with a 2.1A Apple charger but see the same result).

If I connect a separate power supply directly to the display it works as expected (its great !!). It does flash the large rainbow square right at the start, but after that I don’t see any indication that the Pi is not getting sufficient power (no warning icon in the top right).

Any suggestions on how to figure out what might be going on?

/John

ps. as an aside the led in the power button has also stopped illuminating, I’ve not had a chance to dig into whats going on there beyond checking the cables as I have the Picade in the office at the moment with no access to a multimeter.


#2

The screen is powered (can see the OSD menus), and the Picade is running (I can hear the click sounds as I navigate roms in the Retropi menu), but the HDMI output on the Pi sends no signal unless powered separately.


#3

Setting hdmi_safe=1 in /boot/config.txt results in a picture being sent to the display, but its low res.

Setting config_hdmi_boost=4 results in a blank screen again.

My config.txt is here - https://gist.github.com/johnmccabe/3eac71e32e472c8f1b2feeca78b90977

I’d burned a fresh Retropie image to the SD card at the start of the week before running https://get.pimoroni.com/picadehat | bash.


#4

Ok, so I got it working by appending the following to /boot/config.txt

hdmi_force_hotplug=1
config_hdmi_boost=4
hdmi_group=2
hdmi_mode=16

I may not need all of those settings, the group 2/mode 16 hardcodes the 1024x768 @60Hz output.

Bit surprised that I had to make the above changes, could there be something else wrong here?


#5

I ran into the blank screen problem (unless powered separately) during my build too and eventually contacted Support. My problem was solved by adding the ‘hdmi_force_hotplug=1’ line to the config file.


#6

hdmi_force_hotplug=1 should be the only thing you need. Is this missing from our instructions?

Since the screen is powered from the Pi, it actually fires up just a little bit after the Pi and that technically counts as hotplugging, so if the Pi initialises expecting an HDMI screen and doesn’t see one, it’ll default to Composite (which has no detection) instead.


#7

@gadgetoid I didn’t see anything on the instructions poster - I would have expected the change to have been made to config.txt when running the curl | bash. (I’ve raised a PR for that).


#8

But if you’re running the curl | bash from the Picade… how will you see what you’re doing for it to make that config change!? :D

It’s sort of a catch-22 for it to be part of the installer, although there’s probably no harm in it being there.

It should really be manually edited into config.txt right after RetroPie is flashed on the host computer but somehow after all the chaos of dealing with it on the original Picade we neglected to add it into the instructions. DOOOOOOOOOHHHHH!


#9

The curl | bash is already setting the dtoverlay and disabling HDMI audio output, enabling hotplug at the same time seemed innocuous, had never realised it was off by default in Raspbian.

Personally I like when stuff is left out, you learn tons trying to figure out whats going on, lots of fun :)