HDMI LCD quirk


#1

Having just built my picade, I cannot seem to get the LCD to fire up when powering the pi3 on. Instead I have to connect it to a TV via HDMI, then during the boot process I switch the cables and only then will the LCD screen show anything (other than a blue screen which I get when supplying the LCD driver board with power). I guess this maybe a setting but I can’t seem to figure it out.
Hopefully someone can help.


#2

You most likely require hdmi_force_hotplug=1 in your /boot/config.txt

See: Assembled my picade. screen not working. where do i change settings?

Granted this is documented riiiiiiiiiiiggghhhhht at the very bottom of our build instructions, perhaps it should be promoted to the top (thoughts, @sandyjmacdonald?) : https://learn.pimoroni.com/tutorial/picade/build

If you’re a Raspberry Pi user, we’re currently recommending RetroPie as the operating system of choice to run on your Picade.

There are excellent instructions on how to install and configure RetroPie on the RetroPie website.

After installing RetroPie on an SD card, and before booting it up, make sure you edit your /boot/config.txt and add or uncomment (remove the # before) hdmi_force_hotplug=1. Since the display is powered from the Pi it wont be properly detected at startup, so this is required to make it work.


#3

thanks for the reply, awesome service. Honestly I was a little confused
with this one, and I was looking for the config file in the retropie
settings in emulation station. I will un-comment the setting and try again.

Dom