Problems with Blue screen - Picade and retropi installation


#1

Hi,
I bought a Picade, last week and a complete PI 3 kit with 2.5A PSU, pre-installed SD card with Rasbian.

After building the Picade - all OK, I fired up the PI 3 with the installed SD. All seemed OK, and the noobs pre-installed on the SD card (ScanDisk 16GB) went well, screen working fine. (no visible interference I can remember)

I then took the SD and installed Retropi.

All I could see was a blue screen. I tried this 5 or 6 times, same thing. I did notice that the Picade board and joystick seemed to be responding though, sound volume working OK too.

I checked out lots of install guides, tips on HDMI settings, tried these another 6 or 7 installs later still same thing. I even tried a brand new SD card, same thing.

Already tried setting the config fils as suggested to force HDMI.

To check it was not hardware, I re-installed Noobs by downloading the files, looked different from the pre-install SD card though, i.e. less items to choose. This installed OK, but I then noticed the screen shows some red pixilation.

I read a bit more, and tried changing settings in config via a terminal window, but no change to the monitor. Could this be related to heat? There was a small heat sink in the Picade kit, but not sure what it was for. I ended up using it on the PI3 CPU, as I read this could overheat when using Picade. What is the heat sink supplied with Picade for, is it the monitor chip (not tried fitting it here yet)?

What I can’t understand is why it seems worse with new install of Noobs, could it be configuration differences that I’m not aware of? Also if Rasbian install, and the screen sort of works, why can’t I get anything with a clean install RetroPi.

I tried all the cables, checked out different cables. With RetroPi even tried a TV HDMI, same thing, blue screen.

For the red pixcall issue, I tried some online advise changing resolutions, but not clear if it was actually changing anything, and there was no change in display pixilation.

I have run out of ideas now, have red pixilation on noobs, and blue screen on retropie.

Other information: Tried a HDMI TV for retropie - still blue screen, tried different SD card, no effect. I will try TV with Rasbian to see if it’s monitor related.

Please help.

Regards,

Nick


#2

Worked this out myself in the end.
Turned out that editing the config file under windows did not change the contents.
Only editing the file under Linux operating system worked.
Therefore changing the HDMI forced on startup command was the solution after all.
It’s a case of editing the file in Linux. Windows does not seem to work for some reason, even though it looks like it’s changed.


#3

it sounds like you are using NOOBS… if so that would be expected.


#4

No problem with Rasbian (noobs install) , it was only the Retropie config item that required changing,
Like I say, it was because following online video instruction on installing Retropie, made no mention that you could not change the config file in Windows operation system.
It was confusing because windows allowed me to make the change, and showed the change. Only when I looked at the file on the disk in Linux, I could see the config file had not changed at all.


#5

Additional Information on pixilation issue, i.e. I could see some pixels issues with the LCD screen, mostly red pixels.

Turned out that the HDMI cable was too close to the Picade speakers. The magnetic fields must have been inducing some interference in the HDMI cable. Rerouting the cable to avoid the speaker magnets did the trick.


#6

yes, that is what I meant that it would be expected on NOOBS… the FAT partition you see on Windows is for NOOBS itself booting, not the /boot/ partition for your host OS(es).