Raspberry Pi Zero died out of nowhere


#1

Hi everyone!

I got my Raspberry Pi Zero in the mail Tuesday, and I was of course very happy ;). It worked fine with my phone charger (Sony, 2A max), although I couldn’t get the UART to work. I had already soldered on the GPIO header.
Today, I got in some 7805 chips I ordered and I used them to build power modules as described here. I got out my multimeter of course and it was supplying a happy 4,8V. Not as close to the 5V as I’d like it to be, but good enough. I then stripped down a micro-USB cable, soldered it to the module and plugged it into my Pi Zero, after having checked again that the module was still working. Then nothing happened, nothing at all. The LED didn’t turn on, there was no smoke, nothing. I unplugged immediately, but it was too late: the Pi doesn’t work anymore, not even with my phone charger. However, since the B+ has much more power safety onboard, I thought I’d try my module on it: it worked flawlessly!
I could apply for warranty, but the shipping costs back to Great Britain will be the same, if not more, than the amount I would receive :(. So at the moment my question is: why did this happen? I don’t want to fry a second Zero when I get my hands on one.
If it’s any help: the Zero’s 3.3V pin puts out 2.3V now, and the board get’s quite warm near the power-in port and the SD-card slot, which is now empty.

Thanks in advance for all the help!
Red.


#2

I understand it is not much to go on, but I don’t know anything more myself. I just measured the 5V line too, and it puts 6,4V out! The adapter I’m using is putting out 5V though, I measured it just to be sure. My phone charges fine with it, since it is the charger that came with my phone ;). Has anyone seen this problem before? I’m really confused…


#3

I can’t see any way in which it could be outputting 6.4V! Could you post a photo of your full setup including the multimeter (with display visible)?


#4

I couldn’t see a way of it putting out 6,4V either: if it gets warm, it should use energy! As it turns out, when I replaced the battery of my multimeter, it did say 5V for the 5V pin! The 3.3V pin is still at 2.3V though.


#5

It’s getting weirder and weirder! The Zero seems to be working again, the ACT LED starts flashing like it would when booting when I power it up with an SD card and the 3.3V pin gives 3.3V again! It is still getting hot, hotter than when it didn’t work anymore. I don’t feel safe having it on for more than a minute. Does anyone knows what is happening? The Zero doesn’t have a polyfuse, right?